Custom Query (24312 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (97 - 99 of 24312)

Ticket Resolution Summary Owner Reporter
#1311 fixed XML Parsing Error with ff 3.6 / torbutton 1.2.4 jheintb
Description

Now that I have updated FF to 3.6, when I enable torbutton and try to go to any web site, I get:

XML Parsing Error: no element found Location: jar:file:///C:/Program%20Files/Mozilla%20Firefox/chrome/tookit.jar!/content/global/netError.xht[...] Line Number 1, Column 1:

This is with Vista, Firefox/3.6 (.NET CLR 3.5.30729)

This is with a fresh profile and no other add-ons installed.

[Automatically added by flyspray2trac: Operating System: All]

#1319 fixed FAIL test.c:517: assert(fabs(circuit_build_times_cdf(... mikeperry arma
Description

Our buildbot failed its unit tests: https://buildbot.vidalia-project.net/builders/phobos.osx-panther.tor-master/builds/4101/steps/test/logs/stdio

[...] Mar 17 15:19:36.633 [info] circuit_build_times_add_time(): Adding circuit build time 975 Mar 17 15:19:36.633 [info] circuit_build_times_add_time(): Adding circuit build time 2075 Mar 17 15:19:36.633 [info] circuit_build_times_add_time(): Adding circuit build time 8175 Mar 17 15:19:36.633 [info] circuit_build_times_add_time(): Adding circuit build time 825 Mar 17 15:19:36.634 [info] circuit_build_times_parse_state(): Loaded 100/100 values from 72 lines in circuit time histogram Mar 17 15:19:36.638 [info] circuit_build_times_set_timeout(): Set circuit build timeout to 18s (17950.970932ms, Xm: 875, a: 0.532719) based on 100 circuit times Mar 17 15:19:36.645 [info] circuit_build_times_set_timeout(): Set circuit build timeout to 18s (17950.970932ms, Xm: 875, a: 0.532719) based on 100 circuit times Mar 17 15:19:36.645 [warn] Timeout is 17950.970932, Xm is 875

FAIL test.c:517: assert(fabs(circuit_build_times_cdf(&initial, (build_time_t)(30*1000.0)) - circuit_build_times_cdf(&initial, timeout2)) < 0.05) [circuit_timeout FAILED]

Looks like it's an intermittent failure, not a reliable one.

[Automatically added by flyspray2trac: Operating System: All]

#1321 fixed Torbutton Shutdown and Startup State Bug Tordilini
Description

I'm having a problem where I can't get Torbutton to work properly in terms of its shutdown and startup state.

Right now I have on the Startup Settings:

On normal startup, set Tor state to: Shutdown state On session restored startup, set Tor state to Non-tor Have the session store save and restore these tabs:

Tabs loaded in Tor is unchecked Tabs loaded in Non-tor is checked

With these settings, and Vidalia and Polipo running, if I have Torbutton disabled, X out of Firefox and then reopen it, it opens properly with the shutdown state with Torbutton disabled.

With the same settings, if I have Torbutton enabled, X out of Firefox and then re-open it, it starts to open with Torbutton enabled, but then it suddenly switches to disabled and Firefox says in the bottom left corner "Stopped". My homepage's URL loads in the address bar, but the page itself doesn't load. And then Firefox just stays there on a blank page.

My understanding is that it should simply open properly to my homepage (or likely a foreign version of it, as I'll explain) with Torbutton enabled, which was the shutdown state.

So in other words, with these settings, it seems to startup properly if Torbutton is disabled, but improperly if it's enabled.

My homepage is Google.com. With Torbutton enabled, I can tell it's working because it often goes to a foreign Google page rather than US. So, for example, at my current Vidalia IP settings, when Tor is on it is going to Google.de and when it's off it's going to Google.com.

One other interesting note that may shed light on this:

If I change the setting for On session restored startup, set Tor state to: to Tor

then the behavior changes.

With that setting, with Vidalia running, if I have Torbutton disabled, X out of Firefox and re-open it, Firefox opens to my homepage with Torbutton enabled, not the shutdown state of it being disabled. Not only that, but although Torbutton is enabled (which it shouldn't be since my shutdown state was disabled) it goes to Google.com, not Google.de which tells me it isn't actually on, but only claims to be.

With this setting, if I X out of Firefox while Torbutton is enabled, it restarts accurately on my homepage with Torbutton enabled (and shows it is really working because it goes to Google.de, not Google.com)

This points to the fact that perhaps for some reason, Firefox is doing some session-restored startup even when I just X out and then restart Firefox. In both cases, whichever Torbutton state I have set for "On session restored startup, set Tor state to" seems to work properly on re-start if that is the one I have set when I close it. The other state is the one that doesn't work in both cases.

[Automatically added by flyspray2trac: Operating System: All]

Note: See TracQuery for help on using queries.