Opened 6 years ago

Closed 6 years ago

#10055 closed defect (worksforme)

excludenode IP with strictnode 1 includes IP

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client excludenodes
Cc: arma Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Using Tor 0.2.3.25, Firefox 17.0.9esr and the following in torrc:

strictnodes 1
exitnodes {cc}
excludenodes 255.254.0.0/8

(IP and {cc} substituted with non-examples) I often find that 255.254.0.0/8 is my exitnode. I don't understand how that can be possible. I am not sure if this is a bug or if this is caused by something I am configuring wrong. Also, 255.254.0.0/8 is not an address geographically located within {cc}.

Thank you.

Child Tickets

Change History (5)

comment:1 Changed 6 years ago by nickm

Keywords: tor-client excludenodes added
Milestone: Tor: 0.2.4.x-final
Status: newneeds_information

Are you sure it's an exit node, and not just the last node in a circuit? As we use the term, "exit node" means a node that actually delivers traffic to the internet. Tor frequently builds circuits that are not for connecting directly to the internet; those can end with non-exit nodes.

comment:2 in reply to:  1 Changed 6 years ago by cypherpunks

Replying to nickm:

Are you sure it's an exit node, and not just the last node in a circuit? As we use the term, "exit node" means a node that actually delivers traffic to the internet. Tor frequently builds circuits that are not for connecting directly to the internet; those can end with non-exit nodes.

If I receive the check.torproject message 'Your IP address appears to be: 255.254.0.0/8' then would that make 255.254.0.0/8 the IP of the exit node? Nevertheless, shouldn't the excludenodes line prevent the use of the specified address in the entire circuit?

comment:3 Changed 6 years ago by nickm

Cc: arma added

Well, I'm stumped, assuming you have an up-to-date geoip file. (When you start Tor, it doesn't give any warnings about a missing GeoIP file, does it?)

Arma, did we fix any bugs like this between 0.2.3 and 0.2.4?

comment:4 Changed 6 years ago by cypherpunks

I have an idea of what must be going on. I have multiple copies of browser bundle with different configurations. It must be that when I start this copy of tor browser it is running the original torcc file in the original folder, not the copy torcc in the new location with the associated copy of the browser. I should have expected this to happen now that I think about it. If I don't follow up with another post then consider this a non-problem solved.

comment:5 Changed 6 years ago by nickm

Resolution: worksforme
Status: needs_informationclosed

Ah, that sounds like it should explain it. Closing this; please re-open if that turns out not to have been what was going on.

Note: See TracTickets for help on using tickets.