Opened 6 years ago

Closed 6 years ago

#10076 closed defect (duplicate)

Enable accessibility support in Windows TBBs

Reported by: gk Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-3.0
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We disable accessibility support in TBB 3.0 on Windows due to broken compilation with it is enabled:

/home/ubuntu/build/tor-browser/obj-mingw/_virtualenv/bin/python /home/ubuntu/build/tor-browser/config/pythonpath.py -I../../../config /home/ubuntu/build/tor-browser/config/expandlibs_exec.py --depend .deps/IA2Marshal.dll.pp --target IA2Marshal.dll --uselist --  i686-w64-mingw32-g++ -mwindows -shared -Wl,--out-implib -Wl,libIA2Marshal.dll.a -o IA2Marshal.dll  dlldata.o Accessible2_p.o AccessibleAction_p.o AccessibleApplication_p.o AccessibleComponent_p.o AccessibleEditableText_p.o AccessibleHyperlink_p.o AccessibleHypertext_p.o AccessibleImage_p.o AccessibleRelation_p.o AccessibleTable_p.o AccessibleTable2_p.o AccessibleTableCell_p.o AccessibleText_p.o AccessibleValue_p.o Accessible2_i.o AccessibleAction_i.o AccessibleApplication_i.o AccessibleComponent_i.o AccessibleEditableText_i.o AccessibleHyperlink_i.o AccessibleHypertext_i.o AccessibleImage_i.o AccessibleRelation_i.o AccessibleTable_i.o AccessibleTable2_i.o AccessibleTableCell_i.o AccessibleText_i.o AccessibleValue_i.o   ./module.res -Wl,--enable-stdcall-fixup -Wl,--large-address-aware   /home/ubuntu/build/tor-browser/accessible/public/ia2/IA2Marshal.def      -L/home/ubuntu/build/tor-browser/obj-mingw/dist/lib -lmozglue -lkernel32 -lrpcns4 -lrpcrt4 -lole32 -loleaut32    
Executing: i686-w64-mingw32-g++ -mwindows -shared -Wl,--out-implib -Wl,libIA2Marshal.dll.a -o IA2Marshal.dll /home/ubuntu/build/tor-browser/obj-mingw/accessible/public/ia2/tmpDOZPaQ.list module.res -Wl,--enable-stdcall-fixup -Wl,--large-address-aware ../../../../accessible/public/ia2/IA2Marshal.def -L/home/ubuntu/build/tor-browser/obj-mingw/dist/lib -lmozglue -lkernel32 -lrpcns4 -lrpcrt4 -lole32 -loleaut32
/home/ubuntu/build/tor-browser/obj-mingw/accessible/public/ia2/tmpDOZPaQ.list:
    INPUT("dlldata.o")
    INPUT("Accessible2_p.o")
    INPUT("AccessibleAction_p.o")
    INPUT("AccessibleApplication_p.o")
    INPUT("AccessibleComponent_p.o")
    INPUT("AccessibleEditableText_p.o")
    INPUT("AccessibleHyperlink_p.o")
    INPUT("AccessibleHypertext_p.o")
    INPUT("AccessibleImage_p.o")
    INPUT("AccessibleRelation_p.o")
    INPUT("AccessibleTable_p.o")
    INPUT("AccessibleTable2_p.o")
    INPUT("AccessibleTableCell_p.o")
    INPUT("AccessibleText_p.o")
    INPUT("AccessibleValue_p.o")
    INPUT("Accessible2_i.o")
    INPUT("AccessibleAction_i.o")
    INPUT("AccessibleApplication_i.o")
    INPUT("AccessibleComponent_i.o")
    INPUT("AccessibleEditableText_i.o")
    INPUT("AccessibleHyperlink_i.o")
    INPUT("AccessibleHypertext_i.o")
    INPUT("AccessibleImage_i.o")
    INPUT("AccessibleRelation_i.o")
    INPUT("AccessibleTable_i.o")
    INPUT("AccessibleTable2_i.o")
    INPUT("AccessibleTableCell_i.o")
    INPUT("AccessibleText_i.o")
    INPUT("AccessibleValue_i.o")

Creating library file: libIA2Marshal.dll.aAccessible2_p.o:Accessible2_p.c:(.data$_Accessible2_BaseIIDList+0x0): undefined reference to `_IID_IAccessible'
collect2: ld returned 1 exit status

Child Tickets

Change History (1)

comment:1 Changed 6 years ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #9259.

Note: See TracTickets for help on using tickets.