Opened 5 years ago

Closed 5 years ago

#10086 closed defect (fixed)

CONN_BW connection types are poorly defined

Reported by: atagar Owned by:
Priority: Very Low Milestone: Tor: 0.2.5.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay spec
Cc: karsten Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Our recently added CONN_BW events include a ConnType enumeration, but doesn't really describe it. You can mostly guess their meanings, but questions off the top of my head include...

  • Is OR connections both client and inter-tor relay traffic?
  • Is DIR for both mirroring and retrieving descriptors?

Personally I'd suggest breaking the type down more to be 'CLIENT / RELAY / EXIT / DIR / DIR_MIRROR' but that's up to Karsten.

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by atagar

Status: newneeds_review

Pushed a proposed spec change to my 10086 branch. Note that this is just a guess from my part. I have *not* confirmed that this is how tor actually allocates the enumeration (that's up to the feature's author, which I suppose is Karsten).

comment:2 Changed 5 years ago by nickm

Cc: karsten added
Keywords: tor-relay spec added
Milestone: Tor: 0.2.5.x-final

Merged this, since I think it's an improvement. I'd like karsten to sign off on the correctness of the changes before I close this ticket though.

comment:3 Changed 5 years ago by karsten

That spec change looks correct to me. The code simply looks at conn->type and distinguishes between CONN_TYPE_OR, CONN_TYPE_DIR, and CONN_TYPE_EXIT. The comments in or.h seem to match Damian's guesses in the spec change. Feel free to close I'd say.

comment:4 Changed 5 years ago by atagar

Resolution: fixed
Status: needs_reviewclosed

Thanks! Resolving.

Note: See TracTickets for help on using tickets.