Opened 6 years ago

Closed 6 years ago

#10092 closed defect (fixed)

GEOIP fails

Reported by: cypherpunks Owned by: erinn
Priority: High Milestone:
Component: Applications/Tor bundles/installation Version: Tor: 0.2.4.17-rc
Severity: Keywords:
Cc: mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TBB's torrc does not open GEOIP files with relative paths.

OS X 10.9.0
Tor Browser Bundle (2.4.17-rc-1)

OS X 10.8 works

Child Tickets

Change History (5)

comment:1 Changed 6 years ago by dcf

This may be related to #10030, where relative paths to pluggable transport executables weren't working.

comment:2 Changed 6 years ago by mcs

Cc: mcs brade added

comment:3 Changed 6 years ago by mcs

Kathy Brade and I were able to duplicate this problem on OS X 10.9.0. I am 90% certain that the root cause is the same as for #10030: in Mavericks, the current working directory is different when the bundle programs are started. Maybe the launcher script should be modified to reset the current directory? With TBB 3.x, the geoip file is opened by Tor because Tor Launcher passes a fully qualified path to tor on the command line. But PT problems will likely still occur.

comment:4 Changed 6 years ago by arma

The new TBB changelog says this is fixed; but the ticket remains open?

comment:5 Changed 6 years ago by erinn

Resolution: fixed
Status: newclosed

Sorry! Closing.

Note: See TracTickets for help on using tickets.