Opened 6 years ago

Closed 6 years ago

#10101 closed defect (duplicate)

'Failed to open GEOIP file' when adding ExitNodes to torrc of latest TOR Browser Bundle for OSX

Reported by: barf Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The latest versions of the Tor Browser Bundle for OSX Mavericks (I tried 64 bit) seem to malfunction when adding a ExitNodes config line to the torrc inside the app package. This used to work just fine, but now Tor fails to connect and the following is added to the log:

[Notice] Tor v0.2.3.25 (git-17c24b3118224d65) running on Darwin.
[Notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
[Notice] Read configuration file "/Applications/TorBrowser_en-US.app/Contents/MacOS/Vidalia.app/Contents/MacOS/../../../../../Library/Vidalia/torrc".
[Notice] Initialized libevent version 2.0.21-stable using method kqueue. Good.
[Notice] Opening Socks listener on 127.0.0.1:9150
[Notice] Opening Control listener on 127.0.0.1:9151
[Warning] Failed to open GEOIP file ../../Contents/Resources/Data/Tor/geoip. We've been configured to use (or avoid) nodes in certain countries, and we need GEOIP information to figure out which ones they are.
[Notice] No AES engine found; using AES_* functions.
[Notice] This OpenSSL has a good implementation of counter mode; using it.
[Notice] OpenSSL OpenSSL 1.0.0k 5 Feb 2013 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
[Notice] Reloaded microdescriptor cache. Found 4611 descriptors.
[Notice] We now have enough directory information to build circuits.
[Notice] Bootstrapped 80%: Connecting to the Tor network.
[Notice] New control connection opened.
[Notice] All routers are down or won't exit -- choosing a doomed exit at random.
[Warning] No specified exit routers seem to be running: can't choose an exit.
[Warning] failed to choose an exit server
[Notice] Heartbeat: Tor's uptime is 0:00 hours, with 1 circuits open. I've sent 0 kB and received 0 kB.
[Notice] Bootstrapped 85%: Finishing handshake with first hop.
[Notice] Bootstrapped 90%: Establishing a Tor circuit.
[Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
[Notice] Bootstrapped 100%: Done.

Please fix this. It still works fine on Windows.

Child Tickets

Change History (2)

comment:1 Changed 6 years ago by barf

So nobody has noticed this?

comment:2 Changed 6 years ago by dcf

Resolution: duplicate
Status: newclosed

I think this is a duplicate of #10092 and #10135. #10030 has the workaround used in the PT bundle. According to comment:3:ticket:10092, the geoip problem doesn't exist with TBB 3.x.

Note: See TracTickets for help on using tickets.