Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10102 closed defect (fixed)

New random bytes in TBB3 windows builds

Reported by: mikeperry Owned by: erinn
Priority: High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-3.0, tbb-3.0-stable-blocker, MikePerry201311R
Cc: gk, erinn Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

There appear to be new occasional random bytes appearing in the TBB windows builds, similar to #10026 but potentially due to a different underlying cause.

We should get to the bottom of this before the stable.

Child Tickets

Change History (13)

comment:1 Changed 6 years ago by gk

bobnomnom provided the attached binutils patch that I want to test as soon as my compilation machine is not occupied by more pressing things.

Changed 6 years ago by gk

Attachment: bobnomnom_s_binutils_patch added

comment:2 Changed 6 years ago by gk

about:buildconfig of TBB 3.0b1 and TBB < 3.0b1 does not show any difference.

comment:3 Changed 6 years ago by erinn

I have confirmed that bobnomnom's patch fixes the win64 builds! I'll test on win32 now as well.

comment:4 Changed 6 years ago by mikeperry

Keywords: MikePerry201311R added

comment:5 Changed 6 years ago by gk

Status: newneeds_review

Assuming all differences between our last builds are due to the missing memset, the last patch should fix that issue.

comment:6 Changed 6 years ago by mikeperry

Do we need to remove -mwindows for some reason? We need that set to build tor.exe as a non-console app (so it does not display a console text window). See b62e413ae638fe602506d17ba0d8395754ef5430 in tor-browser-bundle.git.

comment:7 Changed 6 years ago by mikeperry

Ah, nevermind. I misread the patch. Bobnomnom pointed out that it was just relocated to below the binutils chunk, probably to make binutils work.

I applied this and am trying a fresh 3.0rc1 build with 95446ee9fef932ba2c443968a90b650a36cd2182. I also commented out the sed hacks, so we can determine if the issues are solved completely now.

comment:8 in reply to:  7 Changed 6 years ago by gk

Replying to mikeperry:

Ah, nevermind. I misread the patch. Bobnomnom pointed out that it was just relocated to below the binutils chunk, probably to make binutils work.

Yes, that's exactly the reason for it.

comment:9 Changed 6 years ago by mikeperry

Resolution: fixed
Status: needs_reviewclosed

3.0rc1 matched, and without any crazy sed hax! Calling this fixed. Thanks Bob; thanks gk!

comment:10 Changed 6 years ago by cfields

I realize this is closed, but since I worked on it for Bitcoin, I'll post here as well:
https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=15b6cd19e80a8e6b9fc86c178fdb03c3bd0ac2fe

I've managed to get changes accepted upstream for deterministic mingw builds. These have been merged into the release branch (Big thanks to Nick Clifton for the quick reviews.) and should appear in binutils 2.24. These changes also address a determinism bug in ar (ar -M specifically) which affects all platforms, though it's unlikely that affects Tor.

If builds still need patching after 2.24 please let me know (I'm easy enough to find), and I'll work to get any determinism-related issues resolved.

Keep up the good work!

Note: See TracTickets for help on using tickets.