Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#10128 closed defect (not a bug)

Search and family very limited

Reported by: kwadronaut Owned by: hellais
Priority: Medium Milestone:
Component: Metrics/Onionoo Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Seems that search is very limited (maybe intentional?)
I get no results in the following cases:

And it goes totally haywire (backend error) if try:

  • to search for a hostname with 2 subdomains
  • put the data from a 'Contact' into the search field (sysdev {at} leap {dot} se)

I took all data from https://atlas.torproject.org/#details/7DE636B00A0B5C4AEDBACA9F44C801F3E00B94AD

Child Tickets

Change History (7)

comment:1 in reply to:  description Changed 6 years ago by karsten

Status: newneeds_information

Replying to kwadronaut:

Seems that search is very limited (maybe intentional?)

Full-text search in Atlas/Onionoo is limited for a reason: it's quite expensive to perform searches on many fields, so we limited those fields to the most important ones. We also shouldn't extend this set of fields now, because we may want to extend the search feature to more than just the past 7 days soon, and we shouldn't make things more complicated than they are.

I get no results in the following cases:

Quite possible that those nodes are not running. In theory, there's no reason why searching for family members of a node shouldn't work.

  • If I search by location (Tried Hong Kong, there are only ~16 nodes)

Onionoo has a country parameter that allows searching by location, but Atlas does not use it. That is mostly an interface problem though. I could imagine an extended search where you pick a country, but I'll leave that to phw and hellais.

  • If I search by hostname (ie: tor.bitmask.net )

True, that's not supported by Onionoo nor Atlas.

And it goes totally haywire (backend error) if try:

  • to search for a hostname with 2 subdomains

Can you be more specific what search does not work? Atlas shouldn't give you a backend error. It should either validate searches before sending them to the Onionoo backend, or maybe there's really an error in Onionoo that we should fix.

  • put the data from a 'Contact' into the search field (sysdev {at} leap {dot} se)

Onionoo has a contact parameter that could be used here; see the country part above. But Atlas shouldn't say "backend error" here either. I just opened #10184 for this.

I took all data from https://atlas.torproject.org/#details/7DE636B00A0B5C4AEDBACA9F44C801F3E00B94AD

Changing to needs_information, because I think I addresses all possible bugs. It would be interesting to learn more about the "backend errors". If you have more such cases, please let us know. Thanks for the report!

comment:2 Changed 5 years ago by karsten

Resolution: user disappeared
Status: needs_informationclosed

Didn't hear anything in the past 7 months. Time to close.

comment:3 Changed 4 years ago by kwadronaut

Following backend errors appear today:

  • IPv6 address (formatted like 2001:858:2:2:aabb:0:563b:1526)
  • ip217-77-61-212-nat.sampo.ru (sampo.ru would tell me 'no results found', probably because hostname field isn't searched?). Anything with 2 dots in it would give me backend error.
Last edited 4 years ago by kwadronaut (previous) (diff)

comment:4 Changed 4 years ago by kwadronaut

Resolution: user disappeared
Status: closedreopened

comment:5 in reply to:  3 Changed 4 years ago by karsten

Component: AtlasOnionoo

Replying to kwadronaut:

Following backend errors appear today:

  • IPv6 address (formatted like 2001:858:2:2:aabb:0:563b:1526)

Well, it does work if you search for "[2001:858:2:2:aabb:0:563b:1526]". Agreed, that's not as user-friendly as it could be. We should consider making the [] optional. Do you think that would be useful? If so, we should create a new ticket for that enhancement.

  • ip217-77-61-212-nat.sampo.ru (sampo.ru would tell me 'no results found', probably because hostname field isn't searched?). Anything with 2 dots in it would give me backend error.

Searching in the hostname field is indeed not supported. I could imagine supporting it by returning all hostnames ending with a given search term. For example, sampo.ru would return that relay and all others in the same domain. It would be a new qualified search term though, that is, you'd have to search for it in Atlas like this: "hostname:sampo.ru". This probably deserves its own ticket.

But can you give an example for a search with 2 dots in it that returns a back-end error?

Changing to component Onionoo, because this is unrelated to Atlas and affects other Onionoo clients as well.

comment:6 Changed 4 years ago by karsten

Resolution: not a bug
Status: reopenedclosed

I just created #16552 and #16553 for the two possible enhancements I suggested above. Given that there was no update in 2 months on the alleged back-end error for searches with 2 dots, I'm closing this ticket again.

comment:7 Changed 4 years ago by kwadronaut

Agreed, couldn't reproduce it no more, spun a dozen new tor nodes up with many dots (no ellipsis).

Note: See TracTickets for help on using tickets.