Opened 7 years ago

Closed 7 years ago

#10133 closed defect (fixed)

Packages not being synced to archive.tpo (and some packages now deleted from it)

Reported by: erinn Owned by: phobos
Priority: Medium Milestone:
Component: Internal Services/Tor Sysadmin Team Version:
Severity: Keywords:
Cc: phobos, mikeperry, ioerror Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

There are several versions of TBB missing from archive.tpo. At the very least 2.3.25-10 through 2.3.15-14, along with the alpha/beta releases. Did a script somewhere break?

Child Tickets

Change History (15)

comment:1 Changed 7 years ago by arma

Cc: phobos added

comment:2 Changed 7 years ago by phobos

the source dir changed at some point. I updated the cronjob and it's now sync'd.

comment:3 Changed 7 years ago by phobos

Resolution: fixed
Status: newclosed

comment:4 Changed 7 years ago by arma

Resolution: fixed
Status: closedreopened

comment:5 Changed 7 years ago by arma

Summary: Packages not being synced to archive.tpoPackages not being synced to archive.tpo (and some packages now deleted from it)

Oops -- now it looks like you deleted other stuff on archive.

In particular,
https://blog.torproject.org/blog/tor-browser-bundle-30beta1-released
points to
https://archive.torproject.org/projects/torbrowser/3.0b1/
which is now a 404.

I don't know what else got deleted too -- perhaps the torbirdy releases?

comment:6 Changed 7 years ago by arma

Cc: mikeperry ioerror added

comment:7 Changed 7 years ago by arma

The entire https://archive.torproject.org/projects now appears to be gone. So, all the TBB 3.x releases.

comment:8 Changed 7 years ago by arma

comment:9 in reply to:  8 Changed 7 years ago by phobos

Replying to arma:

Also, what the heck is https://archive.torproject.org/tor-package-archive/

This is the archive.

comment:10 in reply to:  7 Changed 7 years ago by phobos

Replying to arma:

The entire https://archive.torproject.org/projects now appears to be gone. So, all the TBB 3.x releases.

This shouldn't exist. It seems rsync synced the full website, not just the /dist directory.

comment:11 Changed 7 years ago by phobos

Owner: set to phobos
Status: reopenedaccepted

comment:12 Changed 7 years ago by phobos

I'm purging the website sync from the archive.

comment:13 in reply to:  5 Changed 7 years ago by phobos

Replying to arma:

Oops -- now it looks like you deleted other stuff on archive.

In particular,
https://blog.torproject.org/blog/tor-browser-bundle-30beta1-released
points to
https://archive.torproject.org/projects/torbrowser/3.0b1/
which is now a 404.

It never should have pointed there. They've always been here, https://archive.torproject.org/tor-package-archive/torbrowser/3.0b1/ which is where every revisions of the blog post points to.

I don't know what else got deleted too -- perhaps the torbirdy releases?

Nothing was deleted.

comment:14 Changed 7 years ago by phobos

The website sync has been purged from both archive servers. I've confirmed the cronjob runs as expected on both machines.

comment:15 Changed 7 years ago by phobos

Resolution: fixed
Status: acceptedclosed

appears to be working as expected again.

Note: See TracTickets for help on using tickets.