Opened 7 years ago

Closed 7 years ago

#10147 closed defect (fixed)

Adblock Plus extension interferes with Tor Launcher dialog

Reported by: cypherpunks Owned by: brade
Priority: Medium Milestone:
Component: Applications/Tor Launcher Version:
Severity: Keywords:
Cc: mcs, mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Using TBB 3.0b1 (in Windows 7), the Adblock Plus (version 2.4) extension causes the Tor Launcher dialog box to appear frozen when starting TBB (the progress bar does not move and the progress description text does not appear). Clicking the "Exit" button quites TBB. Clicking "Config" results in the Tor Browser window opening with the about:tor page reporting success. As far as I can tell (from visiting check.torproject.org), I am connected to Tor after launching this way. The Tor Launcher window appears to behave as expected if the extension is installed but disabled. This is the first version of TBB 3.0 I've tried so it is possible this problem existed in the alpha versions.

Child Tickets

Change History (4)

comment:1 Changed 7 years ago by cypherpunks

Component: - Select a componentTor Launcher
Owner: set to brade

comment:2 Changed 7 years ago by brade

Cc: mcs mikeperry added

comment:3 Changed 7 years ago by cypherpunks

Original reporter here. I'm still seeing this with TBB 3.0rc1 (and with the betas since b1). Since reporting this, I've noticed that I do see progress in the Tor Launcher window on a few occasions, but the majority of launches I see the problem originally described (in other words, it's intermittent). I haven't been able to notice a pattern to it. Could it be related to 10248?

comment:4 in reply to:  3 Changed 7 years ago by mcs

Resolution: fixed
Status: newclosed

Replying to cypherpunks:

Original reporter here. I'm still seeing this with TBB 3.0rc1 (and with the betas since b1). Since reporting this, I've noticed that I do see progress in the Tor Launcher window on a few occasions, but the majority of launches I see the problem originally described (in other words, it's intermittent). I haven't been able to notice a pattern to it. Could it be related to 10248?

Thanks for the extra info. Kathy Brade and I were able to reproduce this problem. For some reason, Adblock Plus hangs the browser long enough during startup that the Tor Launcher progress window misses bootstrap progress events from tor. We committed a fix:

https://gitweb.torproject.org/tor-launcher.git/commit/4bbb3e86f314e793f5939ec70993fe9433048b66

The above fix adds code to check the bootstrap status while initializing the progress window (right before installing the bootstrap status observer), which should fix this problem as well as #10248.

Note: See TracTickets for help on using tickets.