Opened 6 years ago

Closed 5 years ago

#10166 closed defect (worksforme)

Gitian should not download Python packages bypassing the Ubuntu repository

Reported by: gk Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-3.0, ff24-esr, gitian, MikePerry201406R, TorBrowserTeam201406
Cc: mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It turns out that compiling Python ourselves is not enough to build Firefox without downloading additional packages. We should make sure that we either ship the necessary packages ourselves or that they get downloaded from the distro (i.e. Ubuntu in our case) archive.

Child Tickets

Change History (5)

comment:1 Changed 6 years ago by mikeperry

Keywords: gitian added
Parent ID: #10103

comment:2 Changed 5 years ago by gk

Cc: mikeperry added
Status: newneeds_information

Mike: I can't reproduce that. What do I need to do to see the bug? I did the following:
1) I started building gitian-firefox.yml but exited the build script just before the configure for the TorBrowser is running
2) Then I started the VM manually, entered it and made sure no network connectivity remained (I unplugged the network cable of the host machine).
3) Running configure and make did not result in any error for me.

Looking at the documentation (https://mxr.mozilla.org/mozilla-central/source/build/docs/python.rst) there should be no additional packages needed:

All Python packages not in the Python distribution are included in the
source tree. So all you should need is a vanilla Python install and you
should be good to go.

(But, admittedly, this file is not in the ESR 24 tree available, so maybe they changed something later on).

comment:3 Changed 5 years ago by gk

Keywords: MikePerry201406R added

Stumbled over this one again while opening #12462.

comment:4 Changed 5 years ago by mikeperry

I am not sure I recall experiencing the original issue here. It looks like all I did was tag this?

I remember there were some issues with building using gitian while fully disconnected from the network, but I don't recall this specifically as one of them.

comment:5 in reply to:  4 Changed 5 years ago by gk

Keywords: TorBrowserTeam201406 added
Resolution: worksforme
Status: needs_informationclosed

Replying to mikeperry:

I am not sure I recall experiencing the original issue here. It looks like all I did was tag this?

Well, I opened this one after you reported the problem IIRC.

I remember there were some issues with building using gitian while fully disconnected from the network, but I don't recall this specifically as one of them.

Okay. Yes, we need the network to update/install additional packages at least. I tested it again and see still no download of additional Python packages while building Tor Browser. Works for me then.

Note: See TracTickets for help on using tickets.