Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#10178 closed defect (fixed)

about:tor fails with TBB using system-wide tor

Reported by: cypherpunks Owned by: mikeperry
Priority: Medium Milestone:
Component: TorBrowserButton Version:
Severity: Keywords: MikePerry201406R
Cc: isis Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Debian Wheezy 64-bit
Tor version 0.2.3.25 (git-3fed5eb096d2d187)
Tor Browser 3.0-beta-1-Linux
Torbutton 1.6.4

When TorLauncher is disabled and Torbutton's custom proxy settings are set to my system-wide tor running on SOCKS port 9050 (or any other non-TorLauncher configuration), about:tor reports "Something Went Wrong! Tor is not working in this browser", although check.torproject.org works just fine.

Testing the proxy settings in the Torbutton preferences dialog results in: "Tor proxy test: No TorCheckResult id found (response not valid XHTML)"

This is a new defect. My configuration worked just fine with the last TBB 3.0-alpha.

Child Tickets

Change History (10)

comment:1 Changed 6 years ago by cypherpunks

Bug still there in Tor Browser 3.0-rc-1-Linux



comment:2 Changed 5 years ago by gk

Does comment 2 in #11751 help? Re: No TorCheckResult id: this was #10189.

comment:3 Changed 5 years ago by isis

Cc: isis added
Status: newneeds_review

I have a patch for this! See this comment on #11751.

comment:4 Changed 5 years ago by gk

Keywords: MikePerry201405R added

comment:5 Changed 5 years ago by mikeperry

Keywords: MikePerry201406R added; MikePerry201405R removed
Resolution: duplicate
Status: needs_reviewclosed

isis: So I think this should be the ticket for your Linux start-tor-browser patch. #11751 was originally by a Windows user.

Repasting https://trac.torproject.org/projects/tor/ticket/11751#comment:6 here for the record.

I have a ​patch, based on brade's bug11641 branch (because they changed the paths around in the Tor
Browser repo), which fixes this by adding documentation on all the TorButton and TorLauncher Firefox 
settings which should be changed, as well as a bash function to help users correctly set their 
TOR_CONTROL_PASSWD with the correct quoting syntax. The patch is a single commit in my 
bug10178_bug11751 branch and my repo is at ​https://github.com/isislovecruft/tor-browser-bundle . It 
also fixes #10178.

Additionally, there is an extra bug10178_bug11751-log-to-file-and-disown branch based on that last 
branch (because I'm not sure if mikeperry would want this patch, but it's what I personally run in my 
start-tor-browser script). It has ​one more commit which makes makes Tor Browser log to a file, and 
then it disowns the Firefox process from the shell and exits the script. This prevents the output from 
ending up in unpredictable places (it often includes full URIs logged from HTTPSEverywhere), and it 
also prevents having a shell remain open during the browser session which is just spewing debugging 
crap all over the place.

Both commits have rather verbose commit messages, explaining the bash syntax and reasoning behind it.

comment:6 Changed 5 years ago by mikeperry

Resolution: duplicate
Status: closedreopened

comment:7 Changed 5 years ago by mikeperry

Resolution: fixed
Status: reopenedclosed

Ok, this has been merged for 4.0-alpha. Thanks Isis!

comment:8 Changed 5 years ago by isis

For the record, I had to rebase my commits, and the branches which were merged are bug10178_bug11751_rebase1 and bug10178_bug11751-log-to-file-and-disown_rebase1.

comment:9 Changed 5 years ago by arma

A user on irc thinks #12948 may be caused by this patch.

comment:10 in reply to:  9 Changed 5 years ago by isis

Replying to arma:

A user on irc thinks #12948 may be caused by this patch.


I thought so too at first, but after mikeperry and I debugged it a bit with the user on IRC, we think it is an issue with the commandline arguments to tor.

Note: See TracTickets for help on using tickets.