Opened 6 years ago

Closed 6 years ago

#10185 closed defect (fixed)

After Windows logout/login, TBB3.0b1 complains it can't start Vidalia

Reported by: cypherpunks Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-3.0
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have TBB3.0b1 installed on 2 different Windows 7 machines. After installing, I am able to launch it normally, and quit TBB and relaunch it fine on both. But on (only) one of them, if I quit TBB, log out of Windows then log back in, TBB will fail to launch, showing a dialog box titled "Error" and containing the text "Unable to start Vidalia". If I don't log out of Windows, I can quit and restart TBB normally on that machine. If I reinstall TBB3.0b1 (either a clean install or reinstalling over the problem install), I can start TBB normally... until the next time I log out of Windows.

I started with a clean install of TBB3.0b1 on both machines, and it is installed in the same location on both (C:\Users\[myusername]\AppData\Roaming\Tor Browser). I'm not sure if this is relevant, but a big difference between the two machines is that I am logging in to a local account on the machine that doesn't have this problem, and to a domain account on the machine that gives the error. On the problem machine, my profile and "My Documents" folder is mapped by our administrators to a folder on the server, but TBB is installed on the local machine. I had TBB2.x installed on the problem machine previously (in the same location) and did not have this problem.

Child Tickets

Change History (4)

comment:1 Changed 6 years ago by cypherpunks

Just for clarification: on the machine with the problem, once I've logged out and logged back in to Windows, the problem persists until I (re)install TBB3.0b1.

comment:2 Changed 6 years ago by erinn

What happens if you remove all Tor and Vidalia data from C:\Users\[myusername]\AppData\Roaming ? What happens also if you only install to C:\Users\[myusername]\AppData\Local? Does the problem go away? (I am unfamiliar with the TBB 3.x Windows installer, but if it's using $APPDATA -- which is Roaming -- then it would need to be reconfigured to install to $LOCALAPPDATA -- which is Local.)

It sounds like there's an old torrc or vidalia.conf lying around somewhere. Which is icky.

comment:3 Changed 6 years ago by cypherpunks

Thanks, installing in "C:\Users\[myusername]\AppData\Local" seems to have done the trick. I can log out and log back in to Windows and no longer see the "Unable to start Vidalia" error.

comment:4 Changed 6 years ago by erinn

Resolution: fixed
Status: newclosed

Okay, that's good news. I'm still a bit perturbed by the Vidalia issue and wonder what caused it, but I'll close this for now. Please reopen if you see anything like that again.

Note: See TracTickets for help on using tickets.