Opened 6 years ago

Closed 5 years ago

#10194 closed enhancement (duplicate)

Allow for preferential bridge assignment to buckets

Reported by: sysrqb Owned by:
Priority: Medium Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Keywords:
Cc: isis Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After #9652 is fixed, we should also provide a way to specify which transports a bucket prefers.

Something along the line of:

FILE_BUCKETS = { "name1": {"size": 10, "pt": ["obfs2", "obfs3"]},
                 "name2": {"size": 15},
                 "foobar": {"size": 3, "pt": ["obfs3"]}}

Which will result in the "name1" bucket containing 10 bridges, where most will support obfs2 and/or obfs3. "name2" bucket will contain 15 bridges, but has no preference for pluggable transports, and "foobar" will contain 3 bridges where most will be obfs3 bridges.

Child Tickets

Change History (2)

comment:1 Changed 6 years ago by isis

Possible duplicate of #4026?

comment:2 Changed 5 years ago by isis

Resolution: duplicate
Status: newclosed

Closing as a duplicate of #4026. It makes sense to me to change the distributor assignment. But the bucket functionality is not really used, and so if a bridge operator wanted their bridges to go to the help desk (or some other party) they should just not give us the descriptor, and give it to that other party themselves. In my opinion. Feel free to reopen.

Note: See TracTickets for help on using tickets.