Opened 6 years ago

Closed 5 years ago

#10199 closed defect (duplicate)

TBB 3.0beta1 (and I'm guessing all ESR-based TBBs) do not support TLS 1.2

Reported by: cypherpunks Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version: Tor: 0.2.4.18-rc
Severity: Keywords: TLS, compatibility, testing, cryptography, needs-triage
Cc: browserprivacy Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

As confirmed via https://www.ssllabs.com/ssltest/viewMyClient.html

Recent non-ESR versions of Firefox can be configured to support TLS 1.2 by changing the security.tls.version.max preference to 3.

More details on the Firefox experience can be found at https://bugzilla.mozilla.org/show_bug.cgi?id=861266

Child Tickets

TicketStatusOwnerSummaryComponent
#10335closedTLS 1.1 also not supportedApplications/Tor bundles/installation

Change History (4)

comment:1 Changed 6 years ago by browserprivacy

Cc: browserprivacy added
Keywords: TLS compatibility testing cryptography added
Version: Tor: 0.2.4.18-rc

comment:2 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:3 Changed 5 years ago by erinn

Component: Tor bundles/installationTor Browser
Owner: changed from erinn to tbb-team

comment:4 Changed 5 years ago by dcf

Resolution: duplicate
Status: newclosed

Marking as a duplicate of #11253, already closed and in TB 3.6.2.

Note: See TracTickets for help on using tickets.