Opened 7 years ago

Closed 6 years ago

#10208 closed defect (fixed)

Mozilla broke the observatory's detection of private browsing mode

Reported by: pde Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Error ``CC['@mozilla.org/privatebrowsing;1'] is undefined'' [x-] in file ``file:///home/pde/.mozilla/firefox/xx18zmvu.httpse%20testing/extensions/https-everywhere@eff.org/components/ssl-observatory.js'', line 394, character 0.

Documentation of the problem is here:

https://developer.mozilla.org/EN/docs/Supporting_per-window_private_browsing

Child Tickets

Change History (1)

comment:1 Changed 6 years ago by pde

Resolution: fixed
Status: newclosed

Fixed in git

Note: See TracTickets for help on using tickets.