Opened 7 years ago

Closed 5 years ago

#10236 closed task (not a bug)

Let user to hide their OS type to be announced

Reported by: ikurua22 Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I join to relay to help netizens, I notice that
my PC's OS type(ex. Linux, BSD, Win) and it's version
are make to public.

In Apache, I can hide my PC's information by set
"ServerToken Prod" flag. Why not Tor?

Please add something like:
RelayAnnounceExtraInfo 0 (1 is default)

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by arma

See the debate at #2988.

We definitely want you to say your version, since we use that for all sorts of statistics and for clients to use or not use your relay depending on its capabilities.

The platform is mostly just there for statistics. We could get rid of it I guess. I am not excited to though. I think we hit a reasonable balance in #2988.

comment:2 Changed 5 years ago by ikurua22

Resolution: not a bug
Severity: Normal
Status: newclosed
Note: See TracTickets for help on using tickets.