Opened 6 years ago

Closed 5 years ago

#10238 closed defect (not a bug)

Torbutton tells users to download an update and then they don't know what to do

Reported by: mttp Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-usability-stoppoint-app, tor, browser, bundle, thandy, autoupdate, tbb-torbutton, TorBrowserTeam201502R
Cc: mikeperry, gk, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have encountered several help requests where users are confused by the alert in Torbutton to download an update for Tor Browser Bundle. When users click on the bold link in Torbutton, they are taken to a page where they can download the up-to-date Tor Browser Bundle. Users get stuck at this point. Many users expect an update to happen automatically and don't realize they need to download the up-to-date browser and probably delete their old one. This is the point at which they email the help desk for what to do next. I am proposing that until Tor Browser Bundle has auto-update functionality, that the wording in Torbutton be modified to indicate that it is not really an "update" users are downloading but rather an "updated Tor Browser Bundle".

Child Tickets

Change History (8)

comment:1 Changed 6 years ago by mttp

This ticket is actually a pull request: https://github.com/mttp/torbutton
I only modified the English language strings. I realize this might create more work for the translators, and sorry about that.

comment:2 Changed 6 years ago by gk

Component: TorbuttonTorBrowserButton
Keywords: tbb-usability added; usability removed
Owner: set to mikeperry

comment:3 Changed 6 years ago by arma

Good point. There is no "update" available. There is simply a newer TBB available.

comment:4 Changed 6 years ago by mcs

Cc: mcs added

comment:5 Changed 5 years ago by erinn

Component: TorBrowserButtonTor Browser
Keywords: tbb-torbutton added
Owner: changed from mikeperry to tbb-team

comment:6 Changed 5 years ago by mikeperry

Keywords: TorBrowserTeam201502R added
Status: newneeds_review

comment:7 Changed 5 years ago by mikeperry

Keywords: tbb-usability-stoppoint-app added; tbb-usability removed

comment:8 Changed 5 years ago by mikeperry

Resolution: not a bug
Status: needs_reviewclosed

Actually, I think that #13406 obsoletes this bug. In fact, when we change the way that UI behaves, the browser *will* in fact begin downloading an update, and the user will not have to download an updated new browser.

Note: See TracTickets for help on using tickets.