Opened 6 years ago

Closed 6 years ago

#10248 closed defect (duplicate)

TBB 3.0rc1 fails to start Tor Browser on restart

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-3.0
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor Browser Bundle 3.0 (every version, Linux and Mac OS X) sometimes fails to start the Tor Browser and hangs with "Connecting to the Tor network". Only after pressing "Open Settings" the browser opens.

It seems that the bootstrapping on the restart is too fast and and the dialog hangs.

Log output:

./start-tor-browser
 
Launching Tor Browser Bundle for Linux in /home/bb/Desktop/tor-browser_en-US
Nov 28 11:19:07.845 [notice] Tor v0.2.4.18-rc (git-1cda452bc136de6b) running on Linux with Libevent 2.0.19-stable and OpenSSL 1.0.1e.
Nov 28 11:19:07.863 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Nov 28 11:19:07.863 [notice] Read configuration file "/home/xxxx/Desktop/tor-browser_en-US/Data/Tor/torrc-defaults".
Nov 28 11:19:07.864 [notice] Read configuration file "/home/xxxx/Desktop/tor-browser_en-US/Data/Tor/torrc".
Nov 28 11:19:07.868 [notice] We were compiled with headers from version 2.0.21-stable of Libevent, but we're using a Libevent library that says it's version 2.0.19-stable.
Nov 28 11:19:07.870 [notice] Opening Socks listener on 127.0.0.1:9150
Nov 28 11:19:07.870 [notice] Opening Control listener on 127.0.0.1:9151
Nov 28 11:19:07.000 [notice] Parsing GEOIP IPv4 file /home/xxxx/Desktop/tor-browser_en-US/Data/Tor/geoip.
Nov 28 11:19:08.000 [notice] We were built to run on a 64-bit CPU, with OpenSSL 1.0.1 or later, but with a version of OpenSSL that apparently lacks accelerated support for the NIST P-224 and P-256 groups. Building openssl with such support (using the enable-ec_nistp_64_gcc_128 option when configuring it) would make ECDH much faster.
Nov 28 11:19:08.000 [notice] We now have enough directory information to build circuits.
Nov 28 11:19:08.000 [notice] Bootstrapped 80%: Connecting to the Tor network.
Nov 28 11:19:08.000 [notice] New control connection opened.
Nov 28 11:19:08.000 [notice] New control connection opened.
Nov 28 11:19:08.000 [notice] Bootstrapped 85%: Finishing handshake with first hop.
Nov 28 11:19:08.000 [notice] Bootstrapped 90%: Establishing a Tor circuit.
Nov 28 11:19:09.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Nov 28 11:19:09.000 [notice] Bootstrapped 100%: Done.

The Browser only starts when the loading dialog shows up before the bootstrapping reaching 100% otherwise it hangs and doesn't show the progress indicator. It sometimes helps if you clear the cache under Data/Tor, because it slows bootstrapping down.

How to reproduce:

  • start Tor Browser
  • exit it
  • start Tor Browser again
  • it will hang

Child Tickets

Attachments (1)

hanging_connecting_to_tor.png (39.5 KB) - added by cypherpunks 6 years ago.
Screenshot of hanging Connecting to the Tor Network dialog

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by cypherpunks

Screenshot of hanging Connecting to the Tor Network dialog

comment:1 Changed 6 years ago by cypherpunks

Summary: TBB 3.0rc1 failes to start Tor Browser on restartTBB 3.0rc1 fails to start Tor Browser on restart

comment:2 Changed 6 years ago by arma

Is this a case of not checking getinfo bootstrap-phase often enough or at the right time?

comment:3 Changed 6 years ago by arma

I can't reproduce it. Is there anything further special about your set-up? (eg really slow cpu and really fast network)?

comment:4 Changed 6 years ago by cypherpunks

It seems that it doesn't check at the right time and bootstrap is already over.
I think the CPU is average the internet is really fast.

comment:5 Changed 6 years ago by gk

Keywords: tbb-3.0 added

comment:6 Changed 6 years ago by cypherpunks

It's nicely reproducable for me on Mac OS X and Debian testing.
If the output reaches "Bootstrapped 100%: Done" before the connection dialog opens the browser won't be open.

comment:7 Changed 6 years ago by mcs

Resolution: duplicate
Status: newclosed

Marking this as a duplicate of #10147. Both problems could be described as "Tor Launcher leaves its progress window open if the tor bootstrap process finishes before the progress window initializes itself."

Note: See TracTickets for help on using tickets.