Opened 6 years ago

Closed 4 years ago

#10284 closed defect (duplicate)

Locale-dependent JS methods may leak language info to content window

Reported by: mikeperry Owned by:
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-fingerprinting-locale, tbb-firefox-patch
Cc: gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

String.localeCompare, Number.toLocaleString, and Date.toLocaleString may leak locale information to the content Window, even if the user is spoofing English.

See also https://bugzilla.mozilla.org/show_bug.cgi?id=769871 and ECMA 402 (http://www.ecma-international.org/ecma-402/1.0/).

Child Tickets

Change History (5)

comment:1 Changed 6 years ago by gk

Cc: gk added

comment:2 Changed 5 years ago by erinn

Keywords: tbb-firefox-patch added

comment:3 Changed 5 years ago by erinn

Component: Firefox Patch IssuesTor Browser

comment:4 Changed 4 years ago by mikeperry

Keywords: tbb-fingerprinting-locale added; tbb-fingerprinting removed

comment:5 Changed 4 years ago by gk

Resolution: duplicate
Status: newclosed

Tracked in #13019, marking this as a duplicate of it.

Note: See TracTickets for help on using tickets.