Opened 6 years ago

Closed 3 years ago

#10318 closed defect (duplicate)

Tor Cloud instances default to 1024 GB of storage space

Reported by: runa Owned by:
Priority: Medium Milestone:
Component: Archived/Tor Cloud Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A user on the tor-relays list reported that his Tor Cloud instance had defaulted to 1024 GB of storage space, which resulted in a $120 bill at the end of the month. It seems AWS has set the default storage space value for our t1.micro instances to 1024 GB in the following regions: us-west-1, us-west-2, ap-northeast-1, ap-southeast-1, sa-east-1, ap-southeast-2, eu-west-1.

I have pinged @AWSSupport on Twitter. It would be good to update the Tor Cloud website with new screenshots of the setup process and a warning informing users to change this value to 4 GB (which is the default for us-east-1).

Child Tickets

Change History (4)

comment:1 Changed 6 years ago by runa

The AWS Support person I talked to said the Tor Cloud images had been configured to use 1024 GB of storage space. I'm not sure how that could have happened.

When I created the images in April 2013, I used a script to build the Tor Cloud instance for us-east-1. Once that instance was registered and published on AWS, I used the AMI copy feature to copy this instance to the other regions. The instance for us-east-1 defaults to 4 GB of storage space, so I wonder if something might have gone wrong in the process of copying the instance to the other regions.

The AWS Support person was unable to help with technical issues, but suggested I post on the AWS forum. I have updated the Tor Cloud website to only display links to instances in the us-east-1 region until this issue has been resolved.

comment:2 Changed 6 years ago by runa

I have posted a question on the AWS forum about this.

comment:3 Changed 6 years ago by runa

A workaround here would be to build new Tor Cloud images for each of the eight regions available, as opposed to just building an image for us-east-1 and using AMI copy. This would require building two images per region; one image for private bridges, another for normal or "public" bridges.

comment:4 Changed 3 years ago by irl

Resolution: duplicate
Severity: Normal
Status: newclosed

This is a duplicate of #10282.

Note: See TracTickets for help on using tickets.