Opened 4 years ago

Last modified 11 days ago

#10408 reopened defect

version information

Reported by: weasel Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-3.0, tbb-usability, needs-triage
Cc: mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Assuming I have an unpacked tbb tree, there doesn't seem to be an obvious way to learn its version. Maybe there should be a VERSION file next to the start-tor-browser script?

Emphasis is on obvious -- I now know the information is hidden away in Docs/sources/versions.

Child Tickets

Change History (11)

comment:1 Changed 4 years ago by arma

Keywords: tbb-3.0 tbb-usability added

See also #10403

comment:2 Changed 4 years ago by mcs

Cc: mcs brade added

about:tor shows the version (but of course you have to start the browser to access it).

comment:3 Changed 3 years ago by erinn

Keywords: needs-triage added

comment:4 Changed 3 years ago by erinn

Component: Tor bundles/installationTor Browser
Owner: changed from erinn to tbb-team

comment:5 Changed 3 years ago by mikeperry

Resolution: not a bug
Status: newclosed

comment:6 Changed 3 years ago by weasel

Resolution: not a bug
Status: closedreopened

comment:7 Changed 3 years ago by arma

weasel, can you provide the motivation here? Is the hope to have some other automated thing read this file? Which automated thing?

comment:8 Changed 3 years ago by weasel

I didn't think of automated things. I, personally, want to know which version an unpacked tree is from.

comment:9 Changed 3 years ago by arma

Does Browser/TorBrowser/Docs/ChangeLog.txt do it for you?

comment:10 Changed 3 years ago by weasel

That really fails the obvious part. How would I ever find that if I didn't know where to look exactly?

comment:11 Changed 11 days ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.