Opened 6 years ago

Closed 21 months ago

#10430 closed enhancement (fixed)

Torbrowser update check mishandles

Reported by: phip Owned by:
Priority: Medium Milestone:
Component: Applications/Torbutton Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The version checking in the TBB 3.5 series is great! But it doesn't seem to handle versions newer than the current release (ie prerelease/RCs) very well.

With tor-browser-linux64-3.5-rc-1_en-US, the landing page says "This browser is out of date" and TorButton links to https://blog.torproject.org/category/tags/tbb-30?os=Linux&arch=x86_64-gcc3#linux, offering me the same version that I'm using.

With tor-browser-linux64-3.5_en-US, the landing page also says "This browser is out of date", and Torbutton links to https://www.torproject.org/download/download-easy.html?os=Linux&arch=x86_64-gcc3#linux, offering me to download a 2.3 series TorBrowser.

The first behavior makes sense in a way: it directs me to a tag on the blog that will have the most recent release or pre-release listed. But it fails as the version I was running was the latest on that list.

The second's behavior makes sense in a way too: it directs me to the current official version. But it fails as it is NOT beneficial to tell a user to downgrade.

In both cases, it seems unwise to cry wolf about the version being out of date. A user, even one savvy enough to use rc builds, might come to disregard the update warnings.

Child Tickets

Change History (2)

comment:1 Changed 2 years ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:2 Changed 21 months ago by gk

Resolution: fixed
Status: newclosed

That's fixed with our different Tor Browser channels.

Note: See TracTickets for help on using tickets.