Opened 6 years ago

Closed 4 years ago

#10475 closed defect (fixed)

OS X: High CPU usage when TBB can't access a site

Reported by: DrMikeTwiddle Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: OS, X, TBB, 3.5, tbb-torbutton
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TBB 3.5 OS X: When a URL can't be accessed for whatever reason (bad Tor connection, bad internet connection, or internet off) TBB seems to get locked into a very high CPU usage situation that it can't remedy itself out of without user interaction (closing the window/tab or new identity etc)

This is not new. Prior versions of TBB on OS X that included Vidalia had the same problem.

Perhaps it's getting stuck in a loop somewhere ?

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by nickm

Component: - Select a componentTorBrowserButton
Owner: set to mikeperry

Can you confirm whether the high CPU usage is happening from the TorBrowser process, or from Tor itself?

comment:2 Changed 5 years ago by erinn

Component: TorBrowserButtonTor Browser
Keywords: tbb-torbutton added
Owner: changed from mikeperry to tbb-team

comment:3 Changed 4 years ago by cypherpunks

Severity: Normal

This is a duplicate of #9659.

comment:4 Changed 4 years ago by teor

Resolution: fixed
Status: newclosed

Please reopen if the issue reoccurs.

Note: See TracTickets for help on using tickets.