Opened 7 years ago

Closed 7 years ago

#10531 closed defect (duplicate)

Firefox crashes when using hardware acceleration

Reported by: tbuehlmann Owned by:
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-crash
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Using Tor Browser 3.5 on Windows 7, Firefox will crash on startup when having the Advanced\General\Browsing\Use hardware acceleration when available setting set.

Problem signature:

Problem Event Name: APPCRASH

Application Name: firefox.exe

Application Version: 24.2.0.0

Application Timestamp: 386d4380

Fault Module Name: d2d1.dll

Fault Module Version: 6.2.9200.16492

Fault Module Timestamp: 50f30d14

Exception Code: c0000005

Exception Offset: 00228506

OS Version: 6.1.7601.2.1.0.256.48

Locale ID: 1031

Additional Information 1: 0a9e

Additional Information 2: 0a9e372d3b4ad19135b953a78882e789

Additional Information 3: 0a9e

Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by cypherpunks

Probably something with DirectX installation, d2d1.dll is windows stuff and not packed with browser. Firefox in past had many crashes with acceleration for different video card, developers fixed those by disabling 2D acceleration while enabled 3D.
So your crash depends on Firefox core code, your video card, drivers for video card and directx maybe.

Does it works for you with original Firefox 24 ESR?

comment:3 Changed 7 years ago by gk

Component: - Select a componentTor bundles/installation
Keywords: tbb-crash added
Resolution: duplicate
Status: newclosed

Duplicate of #9145.

Note: See TracTickets for help on using tickets.