Opened 6 years ago

Closed 6 years ago

#10543 closed defect (fixed)

count_useable_descriptors behaves badly when nothing in ExitNodes has the Exit flag

Reported by: dhill Owned by:
Priority: Medium Milestone: Tor: 0.2.5.x-final
Component: Core Tor/Tor Version: Tor: 0.2.4.19
Severity: Keywords: tor-client 024-backport
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This is Tor 0.2.4.20.

My tor server, auctoritaso, is not being used as an exit node. It is also not marked as being an exit node. I am not sure why.

If I set 'ExitNodes auctoritaso' (for testing) in my torrc, I am unable to use tor-resolve, or bitcoin client (port 8333), etc.

http://torstatus.blutmagie.de/router_detail.php?FP=badcfe681de3510f43232bf97425b72ea9ec11d9

Child Tickets

Change History (6)

comment:1 Changed 6 years ago by nickm

Component: - Select a componentTor
Milestone: Tor: 0.2.4.x-final
Summary: exit node not workingcount_useable_descriptors behaves badly when nothing in ExitNodes has the Exit flag

Being marked with the Exit flag according to the consensus means that you support at least two of the ports 80, 443, and 667. It doesn't mean whether you're an exit node.

Apparently when I set "exitnodes badcfe681de3510f43232bf97425b72ea9ec11d9" in my torrc, I get:

Jan 17 11:08:22.000 [notice] I learned some more directory information, but not enough to build a circuit: We need more descriptors: we have 5012/5172, and can only build 0% of likely paths. (We have 98% of guards bw, 96% of midpoint bw, and 0% of exit bw.)

Oh, interesting! This isn't the bug you thought it was. The issue is that if you have a set of ExitNodes none of which get the Exit flag, Tor never decides that it has enough descriptors to build circuits. That's our bug!

comment:2 Changed 6 years ago by nickm

Status: newneeds_review

Okay, I think that a good fix for this might look something like the one in branch bug10543 in my public repository. I changed it so that if we have 0 candidate ExitNodes without the Exit flag, and we have some exits to consider, we look at non-reject* exit policies rather than at the Exit flag per se.

Needs review.

comment:3 Changed 6 years ago by nickm

Keywords: tor-client 024-backport added

Merged into 0.2.5 after review by Roger.

If it doesn't cause trouble there, let's put it in 0.2.4 as well.

The correct branch to merge is "bug10543_024_v2" .

comment:4 Changed 6 years ago by nickm

Recommendation: unsure. This is a bugfix on 0.2.4.10-alpha, and it's not too huge. Perhaps if 0.2.5.4-alpha is very stable for a while and the patch gives us no trouble

comment:5 Changed 6 years ago by arma

Inclined against backport. This isn't hurting many people, and among the not-many people it's hurting, we don't know how much they've tested the new code.

comment:6 Changed 6 years ago by nickm

Milestone: Tor: 0.2.4.x-finalTor: 0.2.5.x-final
Resolution: fixed
Status: needs_reviewclosed

Okay, no backport to 0.2.4 for these, for stability reasons.

Note: See TracTickets for help on using tickets.