Opened 5 years ago

Closed 2 years ago

#10552 closed defect (duplicate)

Tor Cloud instance creates 1,024 Gigabyte root drive

Reported by: swhalen Owned by:
Priority: Medium Milestone:
Component: Archived/Tor Cloud Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Following the Tor Cloud instructions I created an Amazon AWS cloud Tor bridge and it ran fine for a month. Discovered when the first bill came and the $ were a lot higher than expected that the Amazon AMI (ami-d09403e0) that is the only Tor instance I could find is built from a snapshot that has a 1,024 gigabyte EBS store as it's root drive. Thats a lot for a t1.micro linux instance.

I followed the somewhat outdated Tor Cloud instructions and "clicked through" and did not catch and change storage size to something more reasonable (like 10 gigabytes) when I set it up. The AMI should probably be corrected and the "click next" instructions updated to make sure the drive size is reasonable.

The truly paranoid might suspect someone is actively trying to discourage people from helping Tor by creating more bridges in the Cloud.

You guy's didn't subcontract creating that AMI to the NSA did you <g>.

Child Tickets

Attachments (3)

TorInstanceCreationEBSsize001.png (47.2 KB) - added by swhalen 5 years ago.
Current Default Tor Cloud Instance Size in most Amazon "regions"
TorInstanceCreationEBSsize002.png (49.3 KB) - added by swhalen 5 years ago.
Showing the size can be changed to 4 gb with better instructions
TorInstanceCreationEBSsize003.png (17.3 KB) - added by swhalen 5 years ago.
showing the size change stayed to the launch review page

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by swhalen

Current Default Tor Cloud Instance Size in most Amazon "regions"

Changed 5 years ago by swhalen

Showing the size can be changed to 4 gb with better instructions

Changed 5 years ago by swhalen

showing the size change stayed to the launch review page

comment:1 Changed 5 years ago by swhalen

When I created this ticket I didn't know this was a duplicate (#10318). That ticked was closed with no real resolution that I could see.

I've attached files that I think show that with better instructions for creating a Tor Cloud instance, this problem can be avoided without re-creating the AMI on Amazon.

If people are instructed to NOT "click through" and make sure they change the EBS size on the storage page, they can launch an instance with 4 gigabytes or anything more reasonable than 1 terabyte.

Fixing the AMI instances / region issues would be nice, but it might be a lot of work. Would seem like updating the instruction on https://cloud.torproject.org/ would be the quickest way to NOT have this discourage people from creating more Tor nodes.

comment:2 in reply to:  1 Changed 5 years ago by runa

Replying to swhalen:

When I created this ticket I didn't know this was a duplicate (#10318). That ticked was closed with no real resolution that I could see.

The issue has not been fixed, so the ticket is still open.

I've attached files that I think show that with better instructions for creating a Tor Cloud instance, this problem can be avoided without re-creating the AMI on Amazon.

If people are instructed to NOT "click through" and make sure they change the EBS size on the storage page, they can launch an instance with 4 gigabytes or anything more reasonable than 1 terabyte.

Fixing the AMI instances / region issues would be nice, but it might be a lot of work. Would seem like updating the instruction on https://cloud.torproject.org/ would be the quickest way to NOT have this discourage people from creating more Tor nodes.

Thanks for this! I think fixing the instances should be a priority, followed by updating and improving the instructions and images on the website. I have removed the links to all instances except us-east-1, which is the original instance with 4 GB default storage space.

Another Tor user who ran into this issue had the charges reversed by Amazon. You could contact their support team, point to #10318, and see if they are able to help you.

comment:3 Changed 2 years ago by irl

Resolution: duplicate
Severity: Normal
Status: newclosed

This is a duplicate of #10282.

Note: See TracTickets for help on using tickets.