Opened 6 years ago

Closed 6 years ago

#10554 closed defect (not a bug)

Incorrect error message when invalid DataDirectory is specified in FreeBSD

Reported by: modalexii Owned by:
Priority: Low Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.3.25
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When torrc DataDirectory is invalid, messages output to stderr incorrectly state that Log is invalid.

To reproduce:

  1. Torrc has invalid DataDirectory specification like DataDirectory /foo/does-not-exist or similar
  2. Torrc has valid Log specification of any kind; e.g. Log notice syslog or Log notice file /var/log/tor/notices.log
  3. Start tor as a service, i.e. # Service tor start
  4. Messages written to stderr are as follows:
Jan 04 17:43:01.000 [warn] Couldn't open file for 'Log notice file /var/log/tor': Is a directory
<snip>
Jan 04 17:43:01.000 [warn] Failed to parse/validate config: Failed to init Log options. See logs for details.

To remedy, specify a valid DataDirectory or comment out the line. Tor runs without issue, revealing that the Log specification was not the issue.

# uname -a
FreeBSD 9.2-RELEASE FreeBSD 9.2-RELEASE #0 r255898: Thu Sep 26 22:50:31 UTC 2013     root@bake.isc.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

 # tor --version
Jan 04 18:01:55.249 [notice] Tor v0.2.3.25 (git-17c24b3118224d65) running on FreeBSD.

Child Tickets

Change History (1)

comment:1 Changed 6 years ago by modalexii

Resolution: not a bug
Status: newclosed

This behavior was the result of conflicting settings in torrc and /usr/local/etc/rc.d/tor. Closing.

Note: See TracTickets for help on using tickets.