Opened 6 years ago

Closed 5 years ago

#10574 closed defect (duplicate)

`nsILocalFile` should be replaced with `nsIFile`.

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-torbutton
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Warning: Starting with Gecko 14, nsILocalFile inherits all functions and attributes from nsIFile, meaning that you no longer need to use nsILocalFile. If your add-on doesn't support versions older than 14, you should use nsIFile instead of nsILocalFile.

See bug https://bugzilla.mozilla.org/show_bug.cgi?id=682360 for more information.

components/cookie-jar-selector.js
chrome/content/torbutton.js

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by erinn

Component: TorBrowserButtonTor Browser
Keywords: tbb-torbutton added
Owner: changed from mikeperry to tbb-team

comment:2 Changed 5 years ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #10573.

Note: See TracTickets for help on using tickets.