Opened 6 years ago

Closed 4 years ago

#10579 closed defect (duplicate)

arm crashes when it connects to relay with ExitPolicy reject6

Reported by: torland Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Nyx Version:
Severity: Normal Keywords: arm, ipv6
Cc: maxxer Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I connect arm to a relay with a ipv6 exit policy line in torrc like

ExitPolicy reject6 [c234:5678:a001:5d::136]:22

arm crashes with the following backtrace:

File "/usr/share/arm/starter.py", line 578, in <module>

cli.controller.startTorMonitor(time.time() - initTime)

File "/usr/share/arm/cli/controller.py", line 700, in startTorMonitor

curses.wrapper(drawTorMonitor, startTime)

File "/usr/lib/python2.7/curses/wrapper.py", line 43, in wrapper

return func(stdscr, *args, kwds)

File "/usr/share/arm/cli/controller.py", line 801, in drawTorMonitor

isKeystrokeConsumed = panelImpl.handleKey(key)

File "/usr/share/arm/cli/headerPanel.py", line 180, in handleKey

torTools.getConn().init(torctlConn)

File "/usr/share/arm/util/torTools.py", line 670, in init

self._exitPolicyChecker = self.getExitPolicy()

File "/usr/share/arm/util/torTools.py", line 1345, in getExitPolicy

result = ExitPolicy(entry, result)

File "/usr/share/arm/util/torTools.py", line 2611, in init

self.ipAddressBin += "".join([str((int(octet) >> y) & 1) for y in range(7, -1, -1)])

ValueError: invalid literal for int() with base 10: '[c234'

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by maxxer

Cc: maxxer added

comment:2 Changed 4 years ago by atagar

Resolution: duplicate
Severity: Normal
Status: newclosed

Fixed, this is a duplicate of #16053.

Note: See TracTickets for help on using tickets.