Opened 7 years ago

Closed 7 years ago

#10605 closed defect (not a bug)

incorrect path assigned to LD_LIBRARY_PATH in start-tor-browser

Reported by: konotrea Owned by: erinn
Priority: Medium Milestone: TorBrowserBundle 2.3.x-stable
Component: Applications/Tor bundles/installation Version: Tor: unspecified
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I installed tor-browser-linux64-3.5_en-US.tar.xz by unpacking the archive.
Unpacked gets a directory

./tor-browser_en-US/...

Additionally the user may choose to unpack the directory tree in a previously created own directory.

But in start-tor-browser there is

LD_LIBRARY_PATH="${HOME}/Tor/"

so this path will not be found because the libs are in

${HOME}/[user-created-directory]/tor-browser_en-US/Tor

Nevertheless the software seems to work here. But we want to assure that specific libs get used, so this should be corrected.

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by gk

What about the lines 190ff. in start-tor-browser.sh? They should reset ${HOME} to whatever your current working directory is when starting the script.

comment:2 Changed 7 years ago by konotrea

You're right. Sorry I didn't examine thoroughly enough.

comment:3 Changed 7 years ago by konotrea

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.