#10610 closed defect (fixed)

Tor Browser users don't know if their network is free of obstacles or not

Reported by: mttp Owned by:
Priority: normal Milestone:
Component: Tor Launcher Version:
Keywords: tbb3.5 usability Cc: mikeperry, mcs, gk, brade
Actual Points: Parent ID:
Points:

Description

Users who used to be able to connect to Tor without any problem are emailing the help desk to ask if their network is free of obstacles. I suggest the tor-launcher interface be reworded to indicate that most users will not have to configure anything, or the option to configure bridges be offered later in the interface.

Child Tickets

Attachments (1)

FirstScreen.png (83.6 KB) - added by brade 19 months ago.
Mockup with alternate wording and button label change

Download all attachments as: .zip

Change History (10)

comment:1 Changed 20 months ago by brade

For reference, the current text (displayed above the Connect button) is:

This computer's Internet connection is clear of obstacles. I would like to connect directly to the Tor network.

I propose the following text (modifications welcome):

This computer's Internet connection is clear of obstacles — it is not censored, filtered, or proxied. I would like to connect directly to the Tor network (this will work in most situations).

comment:2 Changed 20 months ago by lunar

I'm not sure how it could be worded, but my feeling is also something like: “If you don't know, then it means that it's likely that you never had to configure anything special, which means that it's highly likely that your connection is not filtered.”

comment:3 Changed 19 months ago by brade

Please look at the mockup that I just attached. It shows some wording changes as well as a new label for the second button. Is this a direction we want to go in?

If someone does not know whether they need special settings, sending them down the "Use Configuration Wizard" path seems like the best option because each screen includes explanatory text.

comment:4 Changed 19 months ago by lunar

Let's picture someone who recently learned about this thing called “Tor” that supposedly protect your privacy while online. “Proxy” and “bridge” are unknown terms to them. “Filter” they can understand, but they never really realized their connection could be filtered because their browser always just worked after entering the Wi-Fi password. I am pretty sure they will be “not sure” and then get asked confusing questions about things they never heard about before…

comment:5 follow-up: Changed 19 months ago by brade

If the other wizard screens are confusing, then they should be improved.

The addition of the phrase "this will work in most situations" was intended to encourage more people to click the Connect button.

I'm not sure how to proceed. On the one hand, we need to make sure that users who need to use bridges, proxies, etc. are given the opportunity to configure things correctly. On the other hand, clicking Connect is probably the right choice for a very high percentage of users.

comment:6 in reply to: ↑ 5 ; follow-up: Changed 19 months ago by lunar

Replying to brade

If the other wizard screens are confusing, then they should be improved.

Configuring a “proxy” is going to be confusing unless you ever have to use one, whatever the
screen says, IMHO.

Knowing what port allows a firewall is a question for the local network administrator, and you don't necessarily want to ask them because it will raise suspicion… And knowing what a “port” is already means you know quite a lot about how the Internet works.

Bridges are probably more easy to grasp, because you just have to copy/paste lines that someone gave you or that you go look on a website.

On the one hand, we need to make sure that users who need to use bridges, proxies, etc. are given the opportunity to configure things correctly.

My reasoning is that users who need to bridges or configure a proxy are likely to know. Or if they don't know, they will know by trying to a direct connection and see it fails.

I think writing “this will work in most situation” and “if unsure use the wizard” sends conflicting messages.

Changed 19 months ago by brade

Mockup with alternate wording and button label change

comment:7 in reply to: ↑ 6 Changed 19 months ago by brade

Replying to lunar:

My reasoning is that users who need to bridges or configure a proxy are likely to know. Or if they don't know, they will know by trying to a direct connection and see it fails.

...

OK. Mark and I created a new mockup that is simpler. I replaced the attached screenshot; please take a look. Hopefully this design will encourage most users to choose Connect while still providing enough information to users who need to choose Configure.

comment:8 Changed 19 months ago by lunar

Yes, the wording feels much better! :)

I wonder if the use of buttons or their placement is what's best UI-wise, but that's another discussion.

comment:9 Changed 19 months ago by brade

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.