Opened 5 years ago

Last modified 16 months ago

#10630 needs_information defect

MacOS TBB 3.5 hang (due to popups?)

Reported by: ebonsi@… Owned by: mikeperry
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-crash, tbb-torbutton
Cc: gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am on the OS X 10.9 running the New Tor Browser Bundle Firefox ESR 24.2.0 and the browser hanged (frozen state) three times. I could not get an example of the process because of the freezing mode that the Browser was. It seems that when it gets to some sites, the site try to send a pop up window and the browser interface refuses to accept and everything hangs from there.

Child Tickets

Change History (8)

comment:1 Changed 5 years ago by mikeperry

Component: - Select a componentTorBrowserButton
Keywords: tbb-crash added
Owner: set to mikeperry
Summary: New Tor Browser Bundle process hangs (3x)MacOS TBB 3.5 hang (due to popups?)

comment:2 Changed 5 years ago by gk

Cc: gk added

Is that reproducible? If so, do you have example sites where this is happening?

comment:3 Changed 5 years ago by cypherpunks

Resolution: duplicate
Status: newclosed

comment:4 Changed 5 years ago by gk

Resolution: duplicate
Status: closedreopened

Might indeed be related to #9901. But nothing sure so far without having some examples to reproduce the problem.

comment:5 in reply to:  description Changed 5 years ago by ebonsi@…

Replying to ebonsi@…:

Hello mikeperry,
Thanks for picking up this bug. I have new information about the crash or hang of the process.

  1. Information:

[Wed Jan 15 21:21:59 2014] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: "microdesc_free_(): Bug: microdesc_free() called from src/or/microdesc.c:379, but md was still referenced 1 node(s); held_by_nodes == 1
"

  1. I was able to get an example of the process but I can only send to you privately. I am also a bug reporter for Apple and for this reason I cannot disclose the system operational private information to the public. (We are bound by this agreement). Therefore, let me know how to proceed. Thanks!

I am on the OS X 10.9 running the New Tor Browser Bundle Firefox ESR 24.2.0 and the browser hanged (frozen state) three times. I could not get an example of the process because of the freezing mode that the Browser was. It seems that when it gets to some sites, the site try to send a pop up window and the browser interface refuses to accept and everything hangs from there.

comment:6 Changed 5 years ago by erinn

Component: TorBrowserButtonTor Browser
Keywords: tbb-torbutton added

comment:7 Changed 4 years ago by cypherpunks

Status: reopenedneeds_information

Is this still an issue with the latest release?

comment:8 Changed 16 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.