Opened 5 years ago

Closed 13 days ago

#10631 closed defect (worksforme)

LinkedIn page freezes Tor Browser

Reported by: bernie.allen Owned by:
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-crash, tbb-usability-website, tbb-firefox-patch
Cc: gk, mikeperry, Sherief Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The following page freezes with Tor Browser Bundle 3.5 on Linux:

http://no.linkedin.com/pub/torfinn-ingolfsen/3/6a9/981

It does not freeze for vanilla Firefox 24 ESR. Occurs on two different Linux machines (one 32-bit, one 64-bit).

Aside: There seems to be no Trac milestone, version, or component applicable to TBB. Am I reporting to the correct tracker?

Child Tickets

Change History (44)

comment:1 Changed 5 years ago by bernie.allen

Summary: LinkedIn page freezes Tor Browser on LinuxLinkedIn page freezes Tor Browser

Reproduced on Windows, therefore not Linux specific.

comment:2 Changed 5 years ago by cypherpunks

Component: - Select a componentTorBrowserButton
Resolution: duplicate
Status: newclosed

comment:3 Changed 4 years ago by arma

I just reproduced this on TBB 3.6.2.

See also
https://blog.torproject.org/blog/tor-browser-362-released#comment-63529

Should we reopen, or is it a new issue?

comment:4 Changed 4 years ago by arma

Cc: gk mikeperry added

comment:5 in reply to:  3 Changed 4 years ago by gk

Resolution: duplicate
Status: closedreopened

Replying to arma:

I just reproduced this on TBB 3.6.2.

How?

comment:6 Changed 4 years ago by arma

On my linux 64-bit tbb 3.6.2, which had some other tabs open and had been in use for a while, I went to the address bar and typed in "linkedin.com" and hit enter.

Soon after, my browser window didn't respond anymore.

I just did it again, same result.

comment:7 Changed 4 years ago by arma

I just tried it on a freshly started linux 64-bit TBB 3.6.2, and the page loaded, but it used a lot of cpu, and after maybe 5 or 10 seconds tor browser is now at 100% cpu and the window won't respond.

comment:8 Changed 4 years ago by Sherief

Confirmed on Linux, I went to linkedin.com without logging in, switched to check irc for a minute then went back to TB to find it all frozen.

comment:9 in reply to:  8 Changed 4 years ago by Sherief

Replying to Sherief:

Confirmed on Linux, I went to linkedin.com without logging in, switched to check irc for a minute then went back to TB to find it all frozen.

Same thing for Windows.

comment:10 Changed 4 years ago by Sherief

Cc: Sherief added

comment:14 Changed 4 years ago by cypherpunks

Component: TorBrowserButtonFirefox Patch Issues

comment:15 Changed 4 years ago by saint

I was able to reproduce this with stock 3.6.2, 32-bit, under Debian 7. Page briefly froze, then unfroze, then entire browser froze. Quite strange.

comment:16 Changed 4 years ago by anon

Also confirmed on tor-browser-linux64-3.6.1_en-US. Let me know if any particular details to be obtained during a hang would be useful.

Note that I don't get a crash unless I let the hang continue un-interrupted for a period of some many seconds. Early on in hang behavior you can close the offending tab and recover browser usable state.

Last edited 4 years ago by anon (previous) (diff)

comment:29 Changed 4 years ago by cypherpunks

Resolution: fixed
Status: reopenedclosed
Last edited 4 years ago by cypherpunks (previous) (diff)

comment:30 Changed 4 years ago by cypherpunks

Component: Firefox Patch IssuesPonies
Priority: normalblocker
Summary: LinkedIn page freezes Tor BrowserFill the web with tadaboom
Type: defecttask

comment:31 Changed 4 years ago by saint

Component: PoniesFirefox Patch Issues
Priority: blockernormal
Summary: Fill the web with tadaboomLinkedIn page freezes Tor Browser
Type: taskdefect

Reverted ticket change made by cypherpunks.

Complaint filed with LinkedIn regarding this bug.

comment:32 Changed 4 years ago by cypherpunks

Resolution: fixed
Status: closedreopened

comment:33 Changed 4 years ago by gk

Keywords: tbb-usability-website added

comment:34 Changed 4 years ago by erinn

Component: Firefox Patch IssuesTor Browser
Keywords: tbb-firefox-patch added

comment:35 Changed 4 years ago by gk

#12755 is a duplicate of this one.

comment:36 Changed 4 years ago by arma

Still an issue on Tor Browser 4.0 (Linux 32-bit).

comment:37 Changed 3 years ago by cypherpunks

Keywords: tbb-crash added
Severity: Normal

comment:38 Changed 2 weeks ago by traumschule

Resolution: fixed
Status: reopenedclosed

Above link gives me an authwall, please reopen if you can reproduce it.

comment:39 Changed 13 days ago by traumschule

Resolution: fixed
Status: closedreopened

Correct resolution

comment:40 Changed 13 days ago by traumschule

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.