Opened 7 years ago

Closed 7 years ago

#10678 closed defect (duplicate)

Gitian OSX Build Fails due to missing .tar.xz file

Reported by: kpdyer Owned by: kpdyer
Priority: Medium Milestone:
Component: Circumvention/Pluggable transport Version:
Severity: Keywords:
Cc: asn, mikeperry, dcf, infinity0 Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When building the 3.6-beta branch of [1], I get the following error.

As a temporary workaround, it is possible to manually download [2] directly and put it in gitian-builder/inputs.

****** Starting Tor Component of Mac Bundle (1/4 for Mac) ******
[snip]
copy-to-target  inputs/multiarch-darwin11-cctools127.2-gcc42-5666.3-llvmgcc42-2336.1-Linux-120724.tar.xz build/
rsync: link_stat "/home/ubuntu/sandbox/gitian-builder/inputs/multiarch-darwin11-cctools127.2-gcc42-5666.3-llvmgcc42-2336.1-Linux-120724.tar.xz" failed: No such file or directory (2)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1070) [sender=3.0.9]
./bin/gbuild:22:in `system!': failed to run copy-to-target  inputs/multiarch-darwin11-cctools127.2-gcc42-5666.3-llvmgcc42-2336.1-Linux-120724.tar.xz build/ (RuntimeError)
	from ./bin/gbuild:87:in `build_one_configuration'
	from ./bin/gbuild:85:in `each'
	from ./bin/gbuild:85:in `build_one_configuration'
	from ./bin/gbuild:224
	from ./bin/gbuild:219:in `each'
	from ./bin/gbuild:219
	from ./bin/gbuild:217:in `each'
	from ./bin/gbuild:217
make: *** [build-beta] Error 1

[1] https://git.torproject.org/user/dcf/tor-browser-bundle.git
[2] https://mingw-and-ndk.googlecode.com/files/multiarch-darwin11-cctools127.2-gcc42-5666.3-llvmgcc42-2336.1-Linux-120724.tar.xz

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by kpdyer

Owner: changed from asn to kpdyer
Status: newassigned

comment:2 Changed 7 years ago by dcf

This sounds a bit familiar to me. I want to say it happens in the main branch too, not only in the new PT code. Do you get the same error with tbb-3.5-build3, for example?

comment:3 Changed 7 years ago by mcs

I just encountered this same issue. It looks like Mike switched the TOOLCHAIN4_PACKAGE in the versions file to x86_64-apple-darwin10.tar.xz as part of this commit:

https://gitweb.torproject.org/builders/tor-browser-bundle.git/commitdiff/322d92715ed4f0935fe4244ab6ad51a2177f70f8

I don't know if that is when things broke, but it seems like corresponding changes would need to be made to descriptors/mac/gitian-tor.yml (files section and tar -Jx command). On the other hand, 3.5.1 was released – so the build must work for Mike and others.

comment:4 Changed 7 years ago by gk

Yes, we have the old compiler still around. The tor descriptor needs to get adapted to work with the new one. Until that happens (which is #10369) the Mac build is broken. Resolving this as a duplicate of #10369.

comment:5 Changed 7 years ago by gk

Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.