Opened 5 years ago

Closed 3 years ago

#10681 closed defect (worksforme)

New Identity may temporarily leak state

Reported by: mikeperry Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-linkability, tbb-torbutton
Cc: gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

While booking tickets to the dev meeting via https://www.kayak.com, I hit New Identity and went back to the booking site immediately, and my destination city was filled in for me in the departure field. This seems a bit odd, especially since it also did not list my departure city in the destination field, or seem to have any other itinerary information from my previous search. Unfortunately, I don't know which exit I was using, but the site also does not normally fill in the departure field for you. Attempts to reproduce the issue also failed.

I don't believe I ever typed in the destination city in the departure field either, and browser.formfill.enable is still set to false. My TBB was storing history, though.

I did have popup windows open, so this may also be a manifestation of #5309 instead of a race condition. I was unable to get it to happen again with other popups, though. New Identity did take a while to close all of my windows in the case where it happened.

There was also a report via email of a twitter account being linked after New Identity some time back that may have been this same issue, or possibly also #5309. I believe we were unable to reproduce that one as well though.

Child Tickets

Change History (9)

comment:1 Changed 5 years ago by gk

Cc: gk added

comment:2 Changed 5 years ago by erinn

Component: TorBrowserButtonTor Browser
Keywords: tbb-torbutton added
Owner: changed from mikeperry to tbb-team

comment:3 Changed 4 years ago by popupbug

I think this a big issue. Seems the new identity option itself does not work properly and carries on from the previous session.

Similar issue where new identity doesn't solve another bug: https://trac.torproject.org/projects/tor/ticket/15387#ticket

comment:4 Changed 4 years ago by cypherpunks

What is the status with this?

comment:5 Changed 4 years ago by olorin

This ticket is pretty old. TBB has been obsolete for a while; Tor Browser restarts on 'New identity'. Are there any indications this has been reproduced in Tor Browser? If not, maybe this can be closed?

comment:6 Changed 3 years ago by fem

Resolution: fixed
Severity: Blocker
Status: newclosed

comment:7 Changed 3 years ago by fem

Severity: BlockerNormal

comment:8 Changed 3 years ago by gk

Resolution: fixed
Status: closedreopened

comment:9 Changed 3 years ago by gk

Resolution: worksforme
Status: reopenedclosed

Seems to work for me.

Note: See TracTickets for help on using tickets.