Opened 7 years ago

Closed 7 years ago

#10699 closed task (fixed)

Find out how many users are currently subscribed to Weather

Reported by: karsten Owned by: karsten
Priority: Medium Milestone:
Component: Metrics/Tor Weather Version:
Severity: Keywords: weather-rewrite
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Blocking on #10698. Once I have access, I'll post some numbers here. These numbers are going to help us decide whether we should put more effort on the part of weather that informs relay operators about problems with their relay, or on the part that emails people (who are not yet subscribed) that they qualify for a t-shirt.

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by karsten

Keywords: weather-rewrite added

comment:2 Changed 7 years ago by karsten

Pasting related ideas from 19 months ago here (from #6281 which is now a duplicate of this ticket):

The goal here is to learn if we can shut down Weather without making too many relay operators sad? In one of the summer dev meeting sessions yesterday afternoon we decided to find a maintainer for Weather and keep it running. Still, having some usage data might help us decide on the priority to finding a maintainer.

I could imagine gathering two stats here:

  • Number of relay operators (un-)registering every day. We can probably learn that from (sanitized) weblogs. Adding Weather's logs to webstats and looking at webalizer output might tell us what we want to know.
  • Number of registered relays and number of such relays which were active in the past month. If someone can give me a dump of relay fingerprints in the database, I can compare that to the consensuses and output the two numbers.

comment:3 Changed 7 years ago by karsten

Resolution: fixed
Status: newclosed

Here's a quick analysis of Weather's database:

  1. How many subscriptions are there in the database? 1 subscription means 1 human subscribing to 1 router.
sqlite> SELECT COUNT(*) FROM weatherapp_subscriber;
2394
  1. How many distinct email addresses have subscribed to notifications, that is, how many different humans are using Weather?
sqlite> SELECT COUNT(*) FROM (SELECT email FROM weatherapp_subscriber GROUP by email);
1846
  1. How many subscriptions have been added per month? Are these all just old subscriptions, or are new subscriptions coming in on a stable basis?
sqlite> SELECT strftime('%Y-%m', sub_date), COUNT(*) FROM weatherapp_subscriber GROUP BY strftime('%Y-%m', sub_date);
2010-10|2
2010-12|1
2011-01|20
2011-02|25
2011-03|14
2011-04|5
2011-05|14
2011-06|11
2011-07|15
2011-08|9
2011-09|6
2011-10|7
2011-11|15
2011-12|10
2012-01|20
2012-02|31
2012-03|19
2012-04|25
2012-05|25
2012-06|5
2012-07|29
2012-08|30
2012-09|17
2012-10|27
2012-11|31
2012-12|49
2013-01|92
2013-02|83
2013-03|108
2013-04|89
2013-05|104
2013-06|129
2013-07|133
2013-08|207
2013-09|189
2013-10|182
2013-11|170
2013-12|182
2014-01|264
  1. How many notification types are in the database? There can be more than 1 notification type per subscription: node is down, version is not recommended, bandwidth is too low, qualifies for t-shirt.
sqlite> SELECT COUNT(*) FROM weatherapp_nodedownsub;
2336
sqlite> SELECT COUNT(*) FROM weatherapp_versionsub;
2157
sqlite> SELECT COUNT(*) FROM weatherapp_bandwidthsub;
1211
sqlite> SELECT COUNT(*) FROM weatherapp_tshirtsub;
2122

In summary, I think Weather has a fairly stable number of users. We shouldn't take away the service from them if we can avoid it.

I'm closing this ticket, because we have the numbers we need. We can still continue the discussions whether numbers are high enough for the effort to fix Weather. But let's discuss that outside of this ticket.

Note: See TracTickets for help on using tickets.