Opened 5 years ago

Closed 5 years ago

#10800 closed defect (fixed)

Clearing the find box can throw an exception on New Identity

Reported by: mikeperry Owned by: mikeperry
Priority: Very High Milestone:
Component: TorBrowserButton Version:
Severity: Keywords: tbb-newnym, MikePerry201402
Cc: gk Actual Points:
Parent ID: Points: 0.5
Reviewer: Sponsor:

Description

SoakedNoddle reported an exception on New Identity related to clearing the find box. Because that code is not protected by a try/catch block, New Identity did not complete, causing all sorts of havoc.

We still don't know why the exception was thrown, nor could we reproduce it, but we should at least wrap the code in a try/catch so New Identity doesn't abort.

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by gk

Cc: gk added

comment:2 Changed 5 years ago by mikeperry

Points: 0.5
Resolution: fixed
Status: newclosed

Fix added to catch the exception and log is in 3.5.2.

Note: See TracTickets for help on using tickets.