Opened 5 years ago

Closed 5 years ago

#10808 closed defect (not a bug)

DNS lookup fails without proxy (TorBrowser without tor)

Reported by: supermario Owned by:
Priority: Medium Milestone:
Component: - Select a component Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi I am trying to use TorBrowser just the browser; no Tor.exe or TorButton or extensions. To do that I installed Tor Browser 3.5 on Windows 7 and then copied out the browser folder. If that's the wrong way to do it please let me know.

I have manual proxy enabled for FTP but I do not have HTTP, HTTPS or SOCKS proxy enabled. When I try to access an http website in TorBrowser it says:

Firefox is configured to use a proxy server that can't be found.

That doesn't make any sense to me since there is no HTTP/HTTPS/SOCKS proxy. If I change 'network.proxy.socks_remote_dns' to false that message goes away.

In Firefox 24 ESR I cannot reproduce. When I have a manual proxy enabled for only FTP, even if network.proxy.socks_remote_dns is set true I can still access HTTP.

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by gk

Resolution: not a bug
Status: newclosed

You can't just use the TorBrowser as there are e.g. preferences relevant for the whole bundle directly included into the browser. That is likely your problem. Anyway, that is not a bug.

Note: See TracTickets for help on using tickets.