Opened 6 years ago

Closed 6 years ago

#10827 closed defect (duplicate)

Torbutton hangs in torbutton_send_ctrl_cmd()

Reported by: gk Owned by: mikeperry
Priority: High Milestone:
Component: TorBrowserButton Version:
Severity: Keywords:
Cc: brade, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

While trying to reproduce #10824 I used the upcoming 3.5.2 (Linux 32bit) and encountered fairly regular hangs I've never seen before. Might be a local glitch or not, I am not sure yet. After some debugging I can pinpoint the problem down to

outputStream.writeBytes(auth_cmd, auth_cmd.length);

That is the last call that gets executed before the hang. Might be related to #10804.

Child Tickets

Change History (2)

comment:2 Changed 6 years ago by gk

Resolution: duplicate
Status: newclosed

Seems I hit #9531 more often now. Marking this one as a duplicate of it.

Note: See TracTickets for help on using tickets.