Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#10852 closed defect (duplicate)

Freeze on loading non-html without trailing newline

Reported by: FiloSottile Owned by: erinn
Priority: High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: DoS, tor-dos
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The browser will consistently completely freeze when loading (over .onion, plain http or file://) a file without a trailing newline that is not parsed as HTML.

To reproduce create a file without a newline at the end and try to open it first named as X.html (works) then as X (freeze, beachball, before drawing the screen)

Version 3.5-MacOS
OSX 10.9

Child Tickets

Change History (3)

comment:1 Changed 6 years ago by FiloSottile

Keywords: DoS added
Priority: normalmajor

I thought about it and I'm going to report this as a remote DoS, bumping it to major priority.

comment:2 Changed 6 years ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #9901.

comment:3 Changed 3 years ago by mikeperry

Keywords: tor-dos added

Canonicalize dos tag to tor-dos

Note: See TracTickets for help on using tickets.