Opened 6 years ago

Closed 6 years ago

#10857 closed defect (not a bug)

Tor Browser: New Identity closes all browser tabs

Reported by: TorTester Owned by:
Priority: Medium Milestone:
Component: Applications/Torbutton Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Creating a new identity in TorBrowser 3.5.1 via the Torbutton closes all open tabs, this was not the case with the old TorBrowser 2.x versions and Vidalia.

Child Tickets

Change History (2)

comment:1 Changed 6 years ago by TorTester

Component: - Select a componentTorbutton

comment:2 Changed 6 years ago by lunar

Resolution: not a bug
Status: newclosed

The browsing session needs to be restart afresh in order to get a “new identity”. Otherwise cookies, history, cache, and several other things can be used to link the previously opened session and the new one.

See also https://trac.torproject.org/projects/tor/wiki/doc/TorBrowserBundle3FAQ#WhydoesNewIdentitycloseallmyopentabs

Note: See TracTickets for help on using tickets.