Opened 5 years ago

Last modified 19 months ago

#10874 needs_information defect

TorButton won't "blink" for update if using local Tor

Reported by: cypherpunks Owned by: mikeperry
Priority: Medium Milestone:
Component: TorBrowserButton Version:
Severity: Normal Keywords:
Cc: gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When using a local Tor and setting TorLauncher not to spawn Tor (about:config, extensions.torlauncher.start_tor is false, as is extensions.torlauncher.prompt_at_startup), the TorButton turns into a big 'X' and doesn't tell me about updates. Even if I had no Tor at all, I still need security updates!

In any case, I still am using Tor. I am using a local system Tor, I do not want to connect twice and I like to manage my bridges and everything else in one place. Thanks!

Child Tickets

Change History (8)

comment:1 Changed 5 years ago by cypherpunks

To clarify, "local system Tor" means Debian package provided by Tor Project.

comment:2 Changed 5 years ago by gk

Component: - Select a componentTorBrowserButton
Owner: set to mikeperry

comment:3 Changed 5 years ago by gk

Cc: gk added

comment:4 Changed 5 years ago by gk

Status: newneeds_information

Is that still a problem for you or was it only a glitch due to the update going live yesterday? If you still have issues, did they show up recently (i.e. did you get the update warning with your setup when you had TBB 3.5 running)? Steps to reproduce using e.g. a fresh TBB 3.5.1 would be good as disabling those two preferences + running a system Tor is clearly not enough for me to trigger this bug.

comment:5 in reply to:  4 Changed 5 years ago by cypherpunks

Replying to gk:

Is that still a problem for you or was it only a glitch due to the update going live yesterday? If you still have issues, did they show up recently (i.e. did you get the update warning with your setup when you had TBB 3.5 running)? Steps to reproduce using e.g. a fresh TBB 3.5.1 would be good as disabling those two preferences + running a system Tor is clearly not enough for me to trigger this bug.

This happened with other updates in the past, I only upgrade as I find out through the blog. I've also changed my proxy settings to use Privoxy at 127.0.0.1:8118 for HTTP, HTTPS, FTP, Gopher. SOCKS is blank.

comment:6 Changed 5 years ago by cypherpunks

On my system with TBB + debian tor + extensions.torlauncher.start_tor=false, the Tor icon is green and it blinks the exclamation mark when there is a TBB update.

But on several friends systems where I've tried to replicate my configuration, the Tor icon always has a red X over it. I've tried and failed several times to figure out what the difference in our configurations is.

Last edited 5 years ago by cypherpunks (previous) (diff)

comment:7 in reply to:  6 Changed 5 years ago by cypherpunks

Replying to cypherpunks:

On my system with TBB + debian tor + {{extensions.torlauncher.start_tor=false}}, the Tor icon is green and it blinks the exclamation mark when there is a TBB update.

But on several friends systems where I've tried to replicate my configuration, the Tor icon always has a red X over it. I've tried and failed several times to figure out what the difference in our configurations is.

Try changing the proxy settings too (see my above comment).

comment:8 Changed 19 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.