Opened 6 years ago

Closed 5 years ago

#10911 closed defect (duplicate)

EntryNodes, StrictNodes, and a long wait -> "Failed to find node for hop 0 of our path"

Reported by: Tulle Owned by:
Priority: Medium Milestone: Tor: 0.2.5.x-final
Component: Core Tor/Tor Version: Tor: 0.2.4.20
Severity: Keywords: tor-client EntryNodes StrictNodes 024-backport
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Problem:

When adding StrictNodes 1 and

EntryNodes fingerprint,fingerprint,fingerprint,fingerprint

to torrc and restarting tor. The connectivity is good. But if i turn off my computer. Go to bed, and turn it on in the morning.

I get this in the log.

Failed to find node for hop 0 of our path. Discarding this circuit.

The first fingerprint in the EntryNodes line is failing. But when you check its in atlas, its online.

To check if it works, i remove all the fingerprints. pick a new one or one of the 3 left. restart tor.

Then the guard that was checked in atlas as up but failed to connect, is added to the EntryNodes line as the only fingerprint.

Tor is restarted and it works fine. The "hop 0" was not offline, but tor failed to see this and did not even move on to the next hop in the line.

My system:

Ubuntu 12.04 64 bit server. using the repositories the latest version of today.
Only StrictNodes 1 and the EntryNodes line were added to torrc.


Log:

Showing the first connection that failed Hop 0 with 4 guards in the list. Then a successful connection with the specific guard that that failed the first time.

Feb 13 19:49:01.000 [notice] Interrupt: exiting cleanly.
Feb 13 19:49:03.000 [notice] Tor 0.2.4.20 (git-0d50b03673670de6) opening log file.
Feb 13 19:49:03.000 [notice] We now have enough directory information to build circuits.
Feb 13 19:49:03.000 [notice] Bootstrapped 80%: Connecting to the Tor network.
Feb 13 19:49:04.000 [notice] 4 entries in guards
Feb 13 19:49:04.000 [warn] Failed to find node for hop 0 of our path. Discarding this circuit.
Feb 13 19:49:04.000 [warn] Failed to find node for hop 0 of our path. Discarding this circuit.
Feb 13 19:49:04.000 [warn] Failed to find node for hop 0 of our path. Discarding this circuit.
Feb 13 19:49:04.000 [warn] Failed to find node for hop 0 of our path. Discarding this circuit.
Feb 13 19:49:05.000 [warn] Failed to find node for hop 0 of our path. Discarding this circuit.
Feb 13 19:49:05.000 [warn] Failed to find node for hop 0 of our path. Discarding this circuit.
Feb 13 19:49:32.000 [notice] Interrupt: exiting cleanly.
Feb 13 19:49:34.000 [notice] Tor 0.2.4.20 (git-0d50b03673670de6) opening log file.
Feb 13 19:49:34.000 [notice] We now have enough directory information to build circuits.
Feb 13 19:49:34.000 [notice] Bootstrapped 80%: Connecting to the Tor network.
Feb 13 19:49:35.000 [notice] New control connection opened.
Feb 13 19:49:35.000 [notice] 1 entries in guards
Feb 13 19:49:35.000 [notice] Bootstrapped 85%: Finishing handshake with first hop.
Feb 13 19:49:36.000 [notice] Bootstrapped 90%: Establishing a Tor circuit.
Feb 13 19:49:36.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Feb 13 19:49:36.000 [notice] Bootstrapped 100%: Done.

Child Tickets

Change History (4)

comment:1 Changed 6 years ago by Tulle

Milestone: Tor: very long term

comment:2 Changed 6 years ago by nickm

Keywords: tor-client 024-backport added
Milestone: Tor: 0.2.5.x-final
Summary: EntryNodes is failing to select guardEntryNodes, StrictNodes, and a long wait -> "Failed to find node for hop 0 of our path"

comment:3 Changed 5 years ago by nickm

I believe this is a duplicate of #9972

comment:4 Changed 5 years ago by nickm

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.