Opened 6 years ago

Closed 6 years ago

#10916 closed enhancement (duplicate)

Increase monitoring of bridges.tp.o

Reported by: sysrqb Owned by: isis
Priority: Medium Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Keywords: nagios, bridgedb-email
Cc: isis, sysrqb, lunar Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Ponticum ran out of disk space, the website remained operational but the email dist and logging failed. After chatting with lunar about it we began discussing additional monitoring for the email distributor. The check_email_delivery[0] nagios plugin was suggested. I also wondered if we should consider whitelisting tp.o addresses for use by the monitoring system (among other reasons).

Monitoring the modification time of assignment.log may also be a good idea, so karsten won't need to tell us. What else should be monitor?

Perhaps this should go into the TSA component, but this isn't actionable yet, so bridgedb seems more appropriate.

[0] http://exchange.nagios.org/directory/Plugins/Email-and-Groupware/check_email_delivery/details

Child Tickets

Change History (2)

comment:1 in reply to:  description Changed 6 years ago by isis

Cc: sysrqb lunar added
Keywords: nagios bridgedb-email added
Owner: set to isis
Status: newassigned

Replying to sysrqb:

After chatting with lunar about it we began discussing additional monitoring for the email distributor. The check_email_delivery[0] nagios plugin was suggested.


Thanks for that suggestion! (I'm adding it to #12802, where this discussion should continue.)

I also wondered if we should consider whitelisting tp.o addresses for use by the monitoring system (among other reasons).


We can't safely whitelist torproject.org email addresses because the torproject.org mailserver doesn't do DKIM. Because of this, I started adding a (email_address, gpg_fingerprint) whitelisting feature, requiring that such whitelisted addresses be signed with a particular key. (See #9332 and note that this feature would present a maintainability nightmare.)

Monitoring the modification time of assignment.log may also be a good idea, so karsten won't need to tell us.


Or Karsten could easily add our email addresses to the script that they already have that alerts them. :) But perhaps this might also be a good idea. Make a ticket for it?



I'm marking this as a duplicate of #12802, since it is about Nagios checks specifically for the Email Distributor and there is already a discussion going on there, even though this ticket is older. I'll make a note of Lunar's suggestion for the specific Nagios script there.

comment:2 Changed 6 years ago by isis

Resolution: duplicate
Status: assignedclosed

Duplicate of #12802.

Note: See TracTickets for help on using tickets.