Opened 6 years ago

Closed 3 years ago

#10919 closed defect (worksforme)

TBB 3.x does not show up in Launchpad on MacOS

Reported by: msfc Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Normal Keywords: tbb-usability-stoppoint-app, needs-triage
Cc: gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After unzipping a 3.x (currently 3.5.2) TBB and copying/moving the result to my OSX (10.9 Mavericks) Applications folder, it fails to appear in Launchpad. I have to open the Applications folder and double-click it there to launch it.

This is a new problem in 3.X. The 2.X series had no problem.

Child Tickets

Change History (9)

comment:1 Changed 6 years ago by gk

Cc: gk added
Component: Tor LauncherTor bundles/installation
Keywords: tbb-usability added
Owner: changed from brade to erinn

Works for me on OS X 10.6.8 with TBB 3.5.2.1. Maybe this is an issue introduced in 10.9? Any OS X 10.7 or 10.8 users here that could test that?

comment:2 Changed 5 years ago by msfc

I *think* this problem is related to the 1/1/2000 date in the bundle causing the Mac's Dock application to not realize the LaunchPad database needed to be updated as its date is much more recent.

After following the instructions at http://www.cnet.com/how-to/how-to-refresh-the-launchpad-in-os-x/ to cause my LaunchPad database to be rebuilt, the TorBundle appeared.

comment:3 in reply to:  1 Changed 5 years ago by msfc

Replying to gk:

Works for me on OS X 10.6.8 with TBB 3.5.2.1. Maybe this is an issue introduced in 10.9? Any OS X 10.7 or 10.8 users here that could test that?

LaunchPad was not introduced until 10.7 (Lion) so I don't know how you can claim it worked in 10.6.8.

comment:4 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:5 Changed 5 years ago by mikeperry

Does this still happen with TBB 4.0? I think none of the TBB devs are actually using MacOS newer than 10.6.

comment:6 Changed 5 years ago by mikeperry

Keywords: tbb-usability-stoppoint-app added; tbb-usability removed

comment:7 Changed 5 years ago by msfc

I uninstalled Tor 4.0.3 using CleanMyMac2, verified that the icon was gone from LaunchPad then reinstalled 4.0.3 in the usual fashion. The icon reappeared in LaunchPad. However I don't think this is cast iron verification that the problem is fixed. It would be better if someone who has never had an application called "TorBrowser" installed, could try installing it.

I think the TBB devs need to update to more recent OS X. They are 4 major releases behind. I am now running 10.10.

comment:8 Changed 3 years ago by mcs

Severity: Normal

I think this is fixed but it is difficult to tell for sure. On my OSX 10.11.6 system, dragging TorBrowser.app to /Applications caused it to appear in LaunchPad after a very short delay (5-10 seconds). But the TorBrowser icon was still present in LaunchPad after I moved TorBrowser.app to the Desktop. To remove it, I had to follow the procedure described here:

http://apple.stackexchange.com/a/150973/198298

I suppose that is Apple's bug; from my limited experience with LaunchPad, it seems to be a little flaky.

comment:9 Changed 3 years ago by gk

Resolution: worksforme
Status: newclosed

Well, it shows up in LaunchPad which is what the ticket was about. Let's close it then I think.

Note: See TracTickets for help on using tickets.