Opened 5 years ago

Closed 4 years ago

Last modified 4 weeks ago

#10937 closed task (fixed)

Remove libpurple dependencies

Reported by: sukhbir Owned by: sukhbir
Priority: Medium Milestone:
Component: Archived/Tor Messenger Version:
Severity: Keywords: SponsorO
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We should build Instantbird without libpurple. It is possible to do this already but it won't be enabled by default on upstream so we need to do this on our builds (deterministic or not).

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by sukhbir

Owner: changed from arlolra sukhbir to sukhbir
Status: newassigned

comment:2 Changed 5 years ago by sukhbir

Keywords: SponsorO added

comment:3 Changed 5 years ago by fqueze

The default build configuration is actually now to build without libpurple, and a specific line needs to be added to the mozconfig to build with libpurple (which we will do for official Instantbird nightlies and releases).

comment:4 Changed 4 years ago by sukhbir

Resolution: fixed
Status: assignedclosed

Like fqueze said, if we want libpurple, it has to be explicitly specified in the mozconfig file, so we are good. Closing this.

comment:5 Changed 4 weeks ago by traumschule

<+sukhe> hello. yes, I think it's fine to close the tickets. thanks for doing what we should done earlier :)

sad but true:
https://blog.torproject.org/sunsetting-tor-messenger

luckily there are alternatives:
https://blog.torproject.org/tor-heart-onion-messaging

.. and maybe someday

Note: See TracTickets for help on using tickets.