Opened 7 years ago

Last modified 5 months ago

#10952 new defect

Tor Browser leaves developer windows open after New Identity

Reported by: anon Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-newnym, tbb-torbutton, gitlab-tb-torbutton
Cc: gk, brade, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When you open menu entry "View Page Source" from a web page, a new window will open showing the source code.
Then, when you select new identity from the onion menu, all tabs are cleared BUT that page/window with source code will stay there, it's not closed.

Tor Browser 3.5.2

Child Tickets

Change History (13)

comment:1 Changed 7 years ago by gk

Cc: gk added
Component: - Select a componentTorBrowserButton
Keywords: tbb-newnym tbb-usability added
Owner: set to mikeperry

Note: that happens for an open browser/error console as well.

comment:2 Changed 6 years ago by erinn

Component: TorBrowserButtonTor Browser
Keywords: tbb-torbutton added
Owner: changed from mikeperry to tbb-team

comment:3 Changed 6 years ago by mikeperry

Keywords: tbb-usability removed
Summary: View Page Source Tor Browser 3.5.2Tor Browser leaves developer windows open after New Identity

comment:4 Changed 5 years ago by gk

Severity: Normal

#18033 is a duplicate, see #5309 as well.

comment:5 Changed 5 years ago by mcs

Cc: brade mcs added

comment:6 Changed 4 years ago by mcs

Resolution: worksforme
Status: newclosed

Using Tor Browser 6.5, I cannot reproduce this problem for "View Page Source" windows.
I think it is okay to leave the Browser Console and other non-content windows open across the New Identity transition, but if anyone disagrees please reopen this ticket.

comment:7 Changed 4 years ago by gk

Resolution: worksforme
Status: closedreopened

We are already closing the current window for added safety and I think we should do this for any other window as well. It leaves out whole classes of corner cases nobody else but us would be caring about by providing always a clean slate.

And, given the bunch of duplicates over time it seems confusing to users that windows stay open between sessions while the main window is going away.

comment:8 Changed 4 years ago by gk

FWIW: This happens for the about window as well: https://blog.torproject.org/blog/tor-browser-70a2-released#comment-241674.

comment:10 Changed 10 months ago by gk

Status: reopenednew

comment:11 Changed 9 months ago by Thorin

and view page info - see #32987 (which I closed as a dupe of this)

comment:12 Changed 9 months ago by Thorin

also see https://trac.torproject.org/projects/tor/ticket/13854#comment:3 for why view page-source is no longer an issue

Last edited 9 months ago by Thorin (previous) (diff)

comment:13 Changed 5 months ago by gk

Keywords: gitlab-tb-torbutton added

Add magic gitlab keyword.

Note: See TracTickets for help on using tickets.