Opened 6 years ago

Closed 6 years ago

#10954 closed enhancement (invalid)

Obfsproxy unstable not delivered alongside nightly Tor PPA

Reported by: funkstar Owned by: lunar
Priority: Medium Milestone:
Component: Archived/Obfsproxy Version:
Severity: Keywords: PPA, Obfsproxy
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I was trying to figure out why an old version of obfsproxy was being installed even though I'm subscribed to the nightly Tor PPA. It seems it either isn't provided or its at the same version as the stable Tor PPA which I'm also opted in to.

Child Tickets

Change History (8)

comment:1 Changed 6 years ago by lunar

What exactly are you calling “Tor PPA”?

Please paste the output of apt-cache policy obfsproxy.

comment:2 Changed 6 years ago by funkstar

What am I calling the Tor PPA?
deb.torproject.org/torproject.org tor-nightly-master-saucy main
deb.torproject.org/torproject.org saucy main

Output of apt-cache policy obfsproxy
Installed: (none)
Candidate: 0.2.3-1~saucy+1
Version Table:
0.2.3-1~saucy+1 0
--TorProject Stable PPA URL--
0.2.1-3 0
--Ubuntu archive PPA URL--

The nightly PPA isn't even mentioned leading me to believe obfsproxy is not included in the nightly PPA for some reason :(

comment:3 Changed 6 years ago by lunar

Resolution: not a bug
Status: newclosed

tor-nightly-master-* components contain automated builds of the master branch of tor. They do not contain other software.

The obfsproxy package is backported in the stable components after it has migrated to Debian testing.

comment:4 Changed 6 years ago by funkstar

Resolution: not a bug
Status: closedreopened
Type: defectenhancement

Then consider this a feature request. It's retarded to have the only way to install nightly obfsproxy be via pip. It should be building into the nightly PPA.

comment:5 in reply to:  4 ; Changed 6 years ago by lunar

Replying to funkstar:

Then consider this a feature request. It's retarded to have the only way to install nightly obfsproxy be via pip. It should be building into the nightly PPA.

Sorry but it won't be in the same component. It would be in obfsproxy-nightly-main-* because this is different software.

asn, is there a ticket for automated nightly build already? In that case, we should close this one. Otherwise, feel free to assign that to me.

But this will be low priority.

comment:6 Changed 6 years ago by funkstar

Owner: changed from asn to lunar
Status: reopenedassigned

I think obfsproxy is becoming as much a part of Tor as anything else, so I personally don't think it should be separate.

But having it available, even in a separate component, would be great too. I just want it to be available!

My search did not find any similar tickets to this one, so I just assigned it to you anyway.

Hopefully this task it not that time consuming to complete.

comment:7 in reply to:  5 Changed 6 years ago by asn

Replying to lunar:

Replying to funkstar:

Then consider this a feature request. It's retarded to have the only way to install nightly obfsproxy be via pip. It should be building into the nightly PPA.

Sorry but it won't be in the same component. It would be in obfsproxy-nightly-main-* because this is different software.

asn, is there a ticket for automated nightly build already? In that case, we should close this one. Otherwise, feel free to assign that to me.

You mean nightly builds of obfsproxy? I don't think there is a ticket about it. Should we pretend it's this ticket? If yes, let's change the subject.

comment:8 Changed 6 years ago by asn

Resolution: invalid
Status: assignedclosed

I opened #11355 for the nightlies task.

Closing this one. Thanks!

Note: See TracTickets for help on using tickets.