Opened 6 years ago

Closed 3 years ago

#11007 closed defect (not a bug)

Add more documentation about EntryGuardAddedBy in the state file

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-client, documentation, tor-03-unspecified-201612
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by nickm)

Document better how EntryGuardAddedBy date is calculated and written in the state file (well, more documentation about all the state file would be also good).

Should we also change the way the date is calculated?

The EntryGuardAddedBy dates in the state file are not sequential because the date is calculated as the real date minus a random date between the real and 30 days before [1].

The reason for this is to avoid revealing the real date the user was online at that date to that entry guard.

The only existent documentation is in doc/state-contents.txt

[1] e->chosen_on_date = time(NULL) - crypto_rand_int(3600*24*30);

Child Tickets

Change History (5)

comment:1 Changed 6 years ago by nickm

Description: modified (diff)
Summary: Add more documentation about the state fileAdd more documentation about EntryGuardAddedBy in the state file

comment:2 Changed 6 years ago by nickm

Keywords: tor-client documentation added
Milestone: Tor: 0.2.???

comment:3 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:4 Changed 3 years ago by nickm

Keywords: tor-03-unspecified-201612 added
Milestone: Tor: 0.3.???Tor: unspecified

Finally admitting that 0.3.??? was a euphemism for Tor: unspecified all along.

comment:5 Changed 3 years ago by nickm

Resolution: not a bug
Severity: Normal
Status: newclosed

Proposal 271, now implemented, removes the use for this state field

Note: See TracTickets for help on using tickets.